Issue with porcupine and Google Wavenet on armv7l with docker

Hello, I have installed rhasspy docker, version 2.5.10, in a Intel CPU without any issue. I tried to configure a Odroid U2 (armv7l with 2GB ram) and use the same Intel CPU configuration (no copy docker files, only configure in the same manner), I can’t run porcupine and Google Wavenet in the armv7l docker image. Both fails on module initialization. The porcupine error:

rhasspy | 2021-05-09 21:23:51,629 INFO success: wake_word entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
rhasspy | 2021-05-09 21:23:51,630 INFO exited: wake_word (exit status 1; not expected)
rhasspy | 2021-05-09 21:23:52,642 INFO spawned: ‘wake_word’ with pid 525
rhasspy | Traceback (most recent call last):
rhasspy | File “/usr/lib/python3.7/”, line 193, in _run_module_as_main
rhasspy | “main”, mod_spec)
rhasspy | File “/usr/lib/python3.7/”, line 85, in _run_code
rhasspy | exec(code, run_globals)
rhasspy | File “/usr/lib/rhasspy/rhasspy-wake-porcupine-hermes/rhasspywake_porcupine_hermes/”, line 15, in
rhasspy | import pvporcupine
rhasspy | File “/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/pvporcupine/”, line 13, in
rhasspy | from .util import *
rhasspy | File “/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/pvporcupine/”, line 57, in
rhasspy | _PV_SYSTEM, _PV_MACHINE = _pv_platform()
rhasspy | File “/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/pvporcupine/”, line 50, in _pv_platform
rhasspy | pv_machine = _pv_linux_machine(platform.machine())
rhasspy | File “/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/pvporcupine/”, line 41, in _pv_linux_machine
rhasspy | raise NotImplementedError(‘Unsupported CPU.’)
rhasspy | NotImplementedError: Unsupported CPU.

Google Wavenet error:

rhasspy | 2021-05-09 21:31:18,056 INFO spawned: ‘text_to_speech’ with pid 725
rhasspy | 2021-05-09 21:31:19,063 INFO success: text_to_speech entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
rhasspy | /usr/lib/rhasspy/rhasspy-tts-wavenet-hermes/bin/rhasspy-tts-wavenet-hermes: line 15: 729 Illegal instruction (core dumped) python3 -m rhasspytts_wavenet_hermes “$@”
rhasspy | 2021-05-09 21:31:19,162 INFO exited: text_to_speech (exit status 132; not expected)

Thanks in advance.

I found a porcupine issue running it on different arm core sbc to raspberry ( Add support for Rock Pi · Issue #394 · Picovoice/porcupine ( This issue says to try latest pvporcupine version (1.9.5), it support differents arm cores to raspberry. Is this project to update pvporcupine dependency to latests one? How can I update virtualenv python dependency in docker image?

I not found the possible cause to google wavenet initialization error yet.

Nothing Rhasspy can do about it, the CPU is unsupported.
GW is a bit more cryptic, but could be the same issue.

It is not a rhasspy error, I found the issue in porcupine github issues page, but it appears to be solved on pvporcupine 1.9.5 version, rhasspy is using 1.9.0 at the moment.