Custom porcupine wake word not working


I am attempting to use porcupine for the wake word and the default/built in wake words that come with porcupine work fine. But I wanted to use a custom one. So I went to the picovoice site and had a custom one created for my system (linux). Testing it in the browser on the picovoice site worked fine. But once I moved the ppn file to my rhasspy server, it didnt work.

I created the porcupine folder in my rhasspy profile since it did not already exist. I copied the ppn file into it and refreshed the list of available keywords. My new keyword showed up so I selected that one and saved my settings. I then tested it by trying to wake up my speaker with that word and it didnt work. I tried switching the keyword to one of the builtin ones, blue berry, bumblebee, porcupine, computer. they all worked. But my custom one did not.

Prior to this I have been using a custom word with snowboy, but it gives my fiance some issues sometimes so I was going to see if porcupine worked better.

im not sure if there is something I did not setup correcty or if there is an issue currently with that feature that I just didnt know about. Anything would be helpful

P.S. I also created a custom word for raspberry pi and tried it one of those. Got the same problem

Thank you!

Rhasspy needs an update for that.
See this topic

Thank you for the reply. I did stumble upon that thread earlier today and tried it out. I actually got it working on a rpi zero with rhasspy install with the .deb.

But I have a follow up question and maybe it belongs on the other thread.
Do you know if there are any tutorials like that one in the thread but for an instance running in a docker container? My main server is a linux server running rhasspy in a container and if I could get it setup there, that would be most ideal for me.

It seems the file paths dont quite match up with at tutorial. For example one of the steps asks to edit this file /usr/lib/rhasspy/rhasspy-supervisor/rhasspysupervisor/ That path on my linux server doesnt exist. But if i search for ‘rhasspysupervisor’ I get the below:


all of which have there own files. So i assume one of them is the correct one to edit but I just dont know which one. I may end up just editing all of them just to be safe

Got this to working following a guide over in the other topic