Can I not play/record audio on with rhasspy?

I have absolutely no idea why I cannot find anyone who had the same problem.

Trying to use rhasspy on (not docker installed) running on a raspberry pi 3b+ through a usb microphone. I can set the audio input/output on the add-on settings to the microphone, but it seems like using the default microphone settings in the settings tab in the web cli gives me errors, so I switched to the “Use arecord directly” option. in the combo box below it, I only have one option: null: Discard all samples (playback) or generate zero samples (capture)*. Same goes for the Sounds setting: it’s either no playback or aplay, so aplay it is.

However, trying to play audio gives me this error:
subprocess.CalledProcessError: Command '['aplay', '-q']' returned non-zero exit status 1.

I have no idea how to configure this so that I can record audio/play audio. Please do help me and please do ask for more information if needed.

What is your OS?

When running a terminal:

  1. what is the output of aplay -l
  2. what is the output of arecord -l

it’s a home assistant OS running directly on a pi – no venvs, not running in a container

on the home assistant terminal, both commands are not found.

Well, there is your problem.

That OS does not have aplay and arecord.
You probably cannot install it either, because it is a stripped down OS.

You are better of installing raspbian and that install Home Assistant.
That way, you can run addons and still have full power of raspbian.

Follow this guide for installing HassIO (now called Home Assistant) on a generic linux machine:

dammit, I’ve assumed that to be a final option because I would have to redo my stuff. Thanks anyway.

Save your config from Home Assistant, that will cut down your time a bit I guess.

Is it related to this? Hassio addon audio faulure after upgrade to 106.5

Hi, I migrated to a Docker-based Home Assistant on Raspbian, and I’m facing audio input/output problems again.

This happens when I press “Speak” on a sentence:

here are the results when I use aplay -l and arecord -l in my terminal:

here is a part of my rhasspy profile I added as per this post:

edit: removed the parts on the profile, added asoundrc config in add-on config:

Ooh, hello, thanks for stopping by. Unfortunately, I’ve since moved on towards having Home Assistant on Docker in Raspbian, and I can’t replicate the original problem anymore. I have a brand new problem though, so I would be very thankful if you can point me somewhere: details

might I also add that I noticed this part in the logs that I think is also some error:

Yeah no matter what I try my problem always revolve back to this one: subprocess.CalledProcessError: Command '['aplay', '-q']' returned non-zero exit status 1.

Does the USB mic also play audio?
If not, your aplay setting will 100% not work because you have put an input device in an output setting.
What have you selected in the Rhasspy output dropdown? And what are the options?

The usb mic does have an audio output – theres a 3.5mm jack that i can plug my earphones in and have audio come out through it as tested on a normal windows device.
my output and input are the same: the mic

1 Like