Wakewords not properly working on Raspberry PI Zero Setup (.deb && docker)

Hi folks.

I would like to share my findings with you about issues I faced with both setups. Either via .deb file and same for the docker installation.

For both setups the wakewords did not work. With the .deb installation I had also other issues due to the systemd startup script and supervisor. But that would be a different story…

So I got both working, but it worked only with Rhasspy Raven. Porcupine and the others did not work at all. I’ve checked the existance of the .ppn files. They were there, but they did not work. I’ve downloaded then manually the correct files for the pi.


  1. create dir and download the correct file. (change the de to your lang. e.g en, fr, it, …)
    mkdir ~/.config/rhasspy/profiles/de/porcupine/ && wget -P ~/.config/rhasspy/profiles/de/porcupine/ https://github.com/Picovoice/porcupine/raw/master/resources/keyword_files/raspberry-pi/computer_raspberry-pi.ppn
  2. Go to Settings - Wakeword - Set Porcupine and add “computer_raspberry-pi.ppn” to Keyword File. Save the config.

et voilà - it should work now.

@synesthesiam: Not sure if I should open a bug report for that. On my main station it worked oob. But I’ve also took the infos about setup on Raspberry Pi Zero into account. So no idea to be honest why it did not work.