Wake word is not waking the listener up

i’ve installed rhasspy using docker from:

if i press the “Wake” button from the web interface, i’m able to say a sentence and see the recognized intent published to MQTT, but saying the wakeup word does nothing. this is the setup for the wakeup word:

i also tried “hey snips” - neither responds - any ideas?

With not much info to go on, I would try turning the sensitivity down and see what happens there.

thanks - i changed it to 0 and it still doesn’t work.

what info should i add here to help understand the problem?

What type of device have you installed the docker on, what kind of mic are you using, and is the log showing anything relevant to this issue ?

the rhasspy docker is installed on raspberry 3 with raspbian buster. the mic i’m using is a playstation eyetoy connected through USB. the log shows nothing when i say the wakeup word.

the mic is working fine though, because if i press the “Wake” button and say a sentence, the correct intent is fired through MQTT - i’m using MQTT.fx to see it.

For giggles, can you switch your wake word to use [Porcupine] and see if works?

that’s gonna be a bit of a pain to setup… but i found another thing - according to
https://rhasspy.readthedocs.io/en/latest/wake-word/#pocketsphinx “smaller the number, the less like the keyphrase is to be observed” so i guess you meant to INCREASE it to 1 instead of lowering to 0?

anyway - tried to set it to 1 and still doesn’t recognize it. is there any way to test pocketsphinx individually?

I am wondering if you have some corrupt files or missing some file for your wake word handler. Switching the wake word handler to Porcupine and if that works we have an answer. Now switching shouldn’t be that bad , just a couple of clicks here and there, I’m not talking about setting up a custom wake word, just use the default, Porcupine wake word, its just for testing.

“Put keyword files in the porcupine directory in your profile” - do i need to do that? whats the format of the file?

If I recall, everything is done for you with the default keyword, you have to place the keyword in if you are not using the default.

ok - just did it - saying “porcupine” works!
so - how do i reinstall pocketsphinx?

Ok ,I think you need to re-download you profile, which is just a click of a button on the setting tab.

Re-Download Profile

Now you might want to backup any Sentence,Words or anything else you might have added, because I do not know if they will be lost with this proccess.

did it, but - moved back to pocketsphinx and the wakeup word doesn’t work

after you re-downloaded, did you train Rhasspy?

Also, make sure:

Listen for wake word on start-up

Is checked

I never got pocketsphinx wakeword to work at all. I used the default Porcupine for a while and then switched to snowboy. Both work without issue. I think your problem is PocketSphinx. (English profiles here)

Hi @impeham

Just for your info check this thread

I have ps3eye and its mic has really low volume by default. Which leads to problems with wakewords and speech recognition.
Maybe it’s your case too

sorry for not answering yesterday - i got this message when tried to post: “You’ve reached the maximum number of replies a new user can create on their first day. Please wait 17 hours before trying again.”

training didn’t solve the issue and yes - “Listen for wake word” is checked.
the eyetoy is not the problem since the intent is being recognized easily - even from a distance if i press the “Wake” command manually before - it’s just waking it up by wake up word is the problem.

Doing a little searching, I have found that a lot of people are in the same boat as you on this, and I am not sure why it works for some and not the other. Is there a reason you are set on using pocketsphinx as your wake word handler? It is 3rd in the list as performance goes, 1st porcuoine, and 2nd snowboy. If you would rather not say porcupine you can choose other wake words they provide. This is a link to a list of them: (choose the folder of you OS)

And, you can also make a custom wake word with porcupine, but you have to renew it every 30 days, which could be a pain. That leads you to using snowboy and creating a custom wake word. Now i think using one of these options will clear up your wake word issue, now to just get your intent issue, fixed.

1 Like


well the reason i use pocketsphinx is that generally i prefer the fully on premise solutions and i thought it was the only one like that. i definitely want to choose a wakeup word and renew it every time is a pain…