Venv build fails on Raspberry Pi 4 bullseye 32 bit

I followed the instructions at Installation - Rhasspy

$ cat /etc/os-release 
PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"

$ python3 --version
Python 3.9.2 

make-install fails because of an unmet dependency for onnxruntime:

ERROR: Could not find a version that satisfies the requirement onnxruntime~=1.6.0 (from larynx~=0.3.0->rhasspy==2.5.11) (from versions: none)
ERROR: No matching distribution found for onnxruntime~=1.6.0 (from larynx~=0.3.0->rhasspy==2.5.11)
WARNING: You are using pip version 20.2.4; however, version 21.3.1 is available.
You should consider upgrading via the '/home/homeassistant/rhasspy/.venv/bin/python -m pip install --upgrade pip' command.

I’ve tried installing the onnxruntime wheel as suggested here to fulfill the dependency, then make && make install.
Same error.

I tried manually installing the wheel within the venv:

$ python3 -m pip install download/armv7/onnxruntime-1.6.0-cp37-cp37m-linux_armv7l.whl
Looking in indexes:,
ERROR: onnxruntime-1.6.0-cp37-cp37m-linux_armv7l.whl is not a supported wheel on this platform.

How to fix the above issue?

1 Like

Python 3.9 and 3.7 (cp37 in the wheel file name) do not match. Maybe you can switch to Python 3.7 or we must ask @synesthesiam to add a matching cp39 wheel. I have just reported a similar problem for aarch64, see

BTW: There is onnxruntime-1.9.1-cp39-cp39-linux_armv7l.whl !

Yes, I’ve now learned about the wheel format name, thanks!
Now that arm64 is officially supported, I’ll switch to arm64 first, then retry.

64bit OS’es are really recommended anyway if you do anything more than a satellite with only wakeword enabled.