Rhasspy using Docker on Synology

Hello everyone,
I have a DS218+ from Synology and I’ve been working on it.
Home Assistant is installed and configured on Docker, I have no issues on this part.

I discovered Rhasspy while looking for a privacy oriented way to control Home Assistant with my voice.

I’m in a bit of trouble concerning the installation.
As I am on a Synology NAS, I go through the Docker UI in order to install packages.

From the GitHub page I found the following :
docker run -d -p 12101:12101
–restart unless-stopped
-v “$HOME/.config/rhasspy/profiles:/profiles”
–device /dev/snd:/dev/snd
synesthesiam/rhasspy-server:latest
–user-profiles /profiles
–profile en

Configuration I tried :
https://justpaste.it/4nj8f

I am sure, I’m close to the truth. I just need a little push.

I get the following error :
Rhasspy: error: the following arguments are required: --profile/-p

Many thanks and good luck for the lockdown if you are concerned.

Hello,

When you launch for the first time your container from the image with GUI Synology, click on advanced parameters then on the tab environment, you’ll find below the section execution command. this is where you need to enter the last part of the docker command found on gitHub, –user-profiles /profiles
–profile en.

You can also connect to your nas using SSH and run directly the full docker command (sudo + docker…). The container will be visible in the GUI and you’ll be able to manage it from there too afterwards.

Hope it helps.

1 Like

Thank you very much.
I tried using SSH earlier with no success, but I was too close to the problem to actually see it…
It was just the “device” line that was causing issue.
I removed it and the container was created successfully.

For future Synology users who will pass by, run this on SSH :
docker run -d -p 12101:12101
–restart unless-stopped
-v “$HOME/.config/rhasspy/profiles:/profiles”
synesthesiam/rhasspy-server:latest
–user-profiles /profiles
–profile en

Create the folder which will contain the profiles, it’s supposed to be created automatically but in my case it wouldn’t.
/var/services/homes/username/.config/rhasspy/profiles

Anyway, thank you again @maxdel
I might see you around now that I’ll start fiddling with with Rhasspy.

1 Like

thanks for your reference.
just remove the quotes ("") after -v and the folder will be created