Problem with Pi 4 using google AIY and Porcupine

Porcupine not working on RPi4 with google AIY

My Rhasspy system consists of a master and several satellites.

The master is running in docker on an i5 linux system.

All of the satellites are running Rhasspy in a docker container on Raspberry Pi’s installed as in
this thread.

The master handles all STT and Intent recognition and all intent handling is done by home assistant, mostly in Node-Red.
Home assistant passes response messages back to the satellites via the HTTP text-to-speech API.

I created the configuration files for each of the satellites by coping the first one and editing the name in each file.

First 2 satellites are RPi 3b’s and have been running fine since January. One is running with a GUI on the Pi OS and a RPi 7" touch screen.

The third satellite was assembled with a RPi Zero W with a google AIY voice kit. It was running fine for a few months. It is noticeably slower to respond than the RPi 3’s, but it works.

The 4th satellite is a RPi4 running RPi OS Lite (32 bit), and installed the AIY kit that was in service with the Pi Zero.

The Pi 4, with known, working hardware seems to work in every way except Porcupine.

It can wake up with the yellow web GUI button and respond to commands (mic works).

I can reconfigure for snowboy wake word and it works.

I tried 2 other sets of google AIY board sets with the same result.

I have not tried any other wakeword software on it.

Any ideas?