Nanotts doesn't respond, no voice

Hi together,
I’m running Rasspy as docker on a Raspberry pi. Installation and first configuration was successful,
wakeword works as expected, intent recognition and handling seems to be ok, but no audio response from nanotts. There is not to much to configure - I’ve de-DE as language in rasspy and my profile.json looks now like this, after removing some duplicate entries i found.


Node-Red produces the following output after the request arrives:
and this is the relevant log data:
[DEBUG:2022-07-13 16:06:34,540] rhasspyserver_hermes: Sent 391 char(s) to websocket
[DEBUG:2022-07-13 16:06:34,535] rhasspyserver_hermes: Sent 391 char(s) to websocket
[DEBUG:2022-07-13 16:06:34,523] rhasspyserver_hermes: Sent 391 char(s) to websocket
[DEBUG:2022-07-13 16:06:34,506] rhasspyserver_hermes: ← NluIntent(input=‘hallo’, intent=Intent(intent_name=‘GetTime’, confidence_score=1.0), site_id=‘default’, id=None, slots=[], session_id=‘default-jarvis_raspberry-pi-9c19ec20-cbfc-4e5c-bc0e-36df6c963fa0’, custom_data=‘jarvis_raspberry-pi’, asr_tokens=[[AsrToken(value=‘hallo’, confidence=1.0, range_start=0, range_end=5, time=None)]], asr_confidence=1.0, raw_input=‘hallo’, wakeword_id=‘jarvis_raspberry-pi’, lang=None)
[DEBUG:2022-07-13 16:06:33,475] rhasspyserver_hermes: Sent 153 char(s) to websocket
[DEBUG:2022-07-13 16:06:28,780] rhasspyserver_hermes: ← HotwordDetected(model_id=’/profiles/de/porcupine/jarvis_raspberry-pi.ppn’, model_version=’’, model_type=‘personal’, current_sensitivity=0.5, site_id=‘default’, session_id=None, send_audio_captured=None, lang=None, custom_entities=None)

Even after a lot of reading I was not able to figure out what’s wrong here. Any help is appreciated.
Thank’s in advance… Jo

First: Welcome to the Rhasspy forum.

The configuration JSON seems to be corrupt (at least what’s now shown here). Might be due to problems when copying to the forum, but better double check that.

(You may take a copy and delete the original to start again clean).

Does you hear a sound when the wakeword is detected? If not, something might be wrong with your docker command

Hi, my wakeword becomes acknowledged, that works. So I don’t think it’s a audio problem

Imo, there’s still a typo in your configuration: “nanots” instead of “nanotts”. Did you edit that directly? According to my personal experience, it’s sufficient to do all the settings in the GUI and not to use the “danger zone”.

Agreed, cannot tell if this solves the issue but it is incorrect.

Okay, back from a business trip I was confident tho fix my problem with a corrected profile.json but
unfortunately nothing has changed. Since I’ve tried a lot and maybe improved the worse I decided to start a new installation from scratch, probably without docker because i’m not very familiar with this stuff. Thank you all for your support, maybe I’ll be back soon… Jo

Just to give a final statement to my problem. I’ve installed Rhasspy on a Raspian Buster without Docker or a virtual environment. Worked nearly immediately except a few more easier problems.
I had no luck with my first attempt to install it on Bulleye. To many problems.

1 Like

Afaik, there’s “only” two of them: libgfortran is “to new” (=> patch the deb file) and mosquitto might need authentification in most recent versions (might apply to buster as well).

For solutions, you might have a look at Bullseye, mosquitto and authentification for remote access