Matrix Voice Audio Streamer settings in Rhasspy

i have recently received a Matrix Voice and want to hook it up to Rhasspy.

I have installed the popular Romkabouter/Matrix-Voice-ESP32-MQTT-Audio-Streamer but am lost on which settings to use to get it to work.

I am sure the device is streaming - i can see audio frame activity:-
image

I have a server Pi and a couple of pi0 satellites.

I assume that i need to set the server audio playing and recording to Hermes MQTT?
What about the wakeword config? How is this done remotely - i have tried the Matrix set to remote and have configured snowboy on the server with the defaults except for a custom wakeword as this is what my satellites are using.
And finally, if i manage to get that far, i assume i can just configure intent handling for home assistant on the server as per normal?

This is what i have tried on my server, but it seems that i am barking up the wrong tree.
I am not getting any response in Rhasspy.

any suggestions appreciated.

Do you have the ESP version? More for clarity than any recommendations

I see your siteID in the Matrix Voice is matrixvoice, but your server is “server”. That should be matrixvoice, so that your server listens to the correct topic.

@longunmin - its a Matrix Voice ESP32 according to the delivery note.

@romkabouter - thanks , that’s all it was. i matched the siteid’s and it worked straight away.

Out of curiosity, how would I connect / use more than 1 matrix? ie, now i have my matrix connected to the server, presumably i would somehow need to use more pi’s?

I found this device pretty easy to get going, but suggest you mention the web interface and Rhasspy (siteid) settings in the getting started guide. I needed to set the MQTT address in the web gui as the build options didn’t seem to work.

Thanks again. I am pretty chuffed with the results.

Then you can change the siteid in the code and flash that code to another device.

You would have to change the servers siteid to server or some other and set the siteids in the different settings for wakeword etc. Then each device will be a sattelite.

You will not need more pi’s, the pi will be the server and the voice devices each are satellites, running without a pi

@romkabouter thanks yet again… that also works.

I flashed the Matrix with a new siteid and added that siteid to all the sections on the server. I can see intents being published in MQTT explorer under the new id.

Unfortunately, my intent handling does not work. On the server I have it set to Home assistant, and publishing as events. This setup on the server does not work for my pi satellites either, but it does work if i publish to HA as events on each pi satellite.

So i think i will have to rethink the way my intents are handled, but this is a separate issue.

Thanks again.