Installation error

I followed to the letter the installation of Rhasspy under virtual environment on a raspberry pi4 with the Denier Buster freshly installed everything is going well until the make install which blocks with the message:

Collecting rhasspy-remote-http-hermes ~ = 0.2.0
Using cached (12 kB)

ERROR: Could not find a version that satisfies the requirement rhasspy-server-hermes ~ = 2.5.1 (from rhasspy == 2.5.0) (from versions: 2.5.0)
ERROR: No matching distribution found for rhasspy-server-hermes ~ = 2.5.1 (from rhasspy == 2.5.0)
make: *** [Makefile: 146: install-rhasspy] Error 1
Help !!!

I also installed rhasspy today and I got the exacr same error message… what can be wrong?


I believe that the requirements.txt has not been updated to show the latest builds. I had the same trouble some time ago with the 2.5.0pre.

UP for solution at this bug

With New version 2.5.3
I just redo the complete installation and again the same bug with a +1 index on the versions!

HELP !!!

Are you running ./configure --enable-in-place or just ./configure?

I also installed rhasspy today with this parameters :

./configure RHASSPY_LANGUAGE=fr --enable-in-place

And it’s OK !!! :smile:

Thank’s synesthesiam :+1: :+1: :+1: :+1: