Home Assistant and Rhasspy Built-In Intents NOT working

Hi,

Thanks to everybody.

My configuration:

  • Home Asssintant 2021.3.4 and Rhasspy 2.5.9 running as an Add-on
  • Configuration.yaml with intent: added
  • Sentences created and working fine:
    [HassTurnOff]
    turn off the (moon){name}

*moon is the name of a light in HA

Problem: Rhasspy recognize correctly the sentence when I said it or when I write it on the Recognize button, but nothing happens on HA.
I don’t see any communication error on Rhasspy log, and I don’t know if the URL is correct for an add-on installation. I tried to find a log on HA side, but didn’t find anything about the Intent request.

Rhasspy log:
[DEBUG:2021-03-19 12:32:23,060] rhasspyserver_hermes: Sent 560 char(s) to websocket
[DEBUG:2021-03-19 12:32:23,046] rhasspyserver_hermes: Publishing 18 bytes(s) to rhasspy/handle/toggleOn
[DEBUG:2021-03-19 12:32:23,044] rhasspyserver_hermes: -> HandleToggleOn(site_id=‘base’)
[DEBUG:2021-03-19 12:32:23,040] rhasspyserver_hermes: Handling NluIntent (topic=hermes/intent/HassTurnOff, id=12c0f32b-6f88-4daf-bb8e-fe7125e8ddc3)
[DEBUG:2021-03-19 12:32:23,039] rhasspyserver_hermes: <- NluIntent(input=‘turn off the moon’, intent=Intent(intent_name=‘HassTurnOff’, confidence_score=1.0), site_id=‘base’, id=‘b9b9ace2-1678-4378-8242-168b44fdf458’, slots=[Slot(entity=‘name’, value={‘kind’: ‘Unknown’, ‘value’: ‘moon’}, slot_name=‘name’, raw_value=‘moon’, confidence=1.0, range=SlotRange(start=13, end=17, raw_start=13, raw_end=17))], session_id=‘b9b9ace2-1678-4378-8242-168b44fdf458’, custom_data=None, asr_tokens=[[AsrToken(value=‘turn’, confidence=1.0, range_start=0, range_end=4, time=None), AsrToken(value=‘off’, confidence=1.0, range_start=5, range_end=8, time=None), AsrToken(value=‘the’, confidence=1.0, range_start=9, range_end=12, time=None), AsrToken(value=‘moon’, confidence=1.0, range_start=13, range_end=17, time=None)]], asr_confidence=None, raw_input=‘turn off the moon’, wakeword_id=None, lang=None)
[DEBUG:2021-03-19 12:32:22,927] rhasspyserver_hermes: Publishing 203 bytes(s) to hermes/nlu/query
[DEBUG:2021-03-19 12:32:22,926] rhasspyserver_hermes: -> NluQuery(input=‘turn off the moon’, site_id=‘base’, id=‘b9b9ace2-1678-4378-8242-168b44fdf458’, intent_filter=None, session_id=‘b9b9ace2-1678-4378-8242-168b44fdf458’, wakeword_id=None, lang=None)
[DEBUG:2021-03-19 12:32:22,922] rhasspyserver_hermes: Publishing 18 bytes(s) to rhasspy/handle/toggleOff
[DEBUG:2021-03-19 12:32:22,920] rhasspyserver_hermes: -> HandleToggleOff(site_id=‘base’)

Did you add

intent:

in your configuration.yaml of Home Assistant?

Yes it is, in combination with a separate file for intents for clarity

configuration.yaml:

intent: 
intent_script: !include intents.yaml    

intents.yaml:

GetTime:
  speech:
    text: Het is nu {{ now().strftime("%H %M") }}