Hassio addon audio faulure after upgrade to 106.5

HI guys!

Does anyone else have the issue with hassio addon?
Now I have this in addon settings:

But previously I had devices like this:

Also I’ve create a post on HA forum, as I believe the issue is in the last HA update.

Hey :slight_smile:

also replied to you in the Home assistant Forum :slight_smile:

Same Problem. I guess the newest supervisor (209) is causing this.

What's Changed

    Fix Issue with pulse folder (#1573) @pvizeli
    Enforce Pulse client (#1572) @pvizeli
    Bump packaging from 20.1 to 20.3 (#1570) @dependabot-preview

But have no idea how to fix this

Hi @Sikk
Yes, bad news…

Also found more info here https://developers.home-assistant.io/docs/hassio_addon_config/

We map a working PulseAudio setup into container. If you application did not support PulseAudio, you need maybe install: Alpine alsa-plugins-pulse or debian/ubunut libasound2-plugins.

I think they mean we should do this inside docker container (add install statement in rhasspy Docker file)… but the easier way is to migrate from addon to pure docker installation :face_with_raised_eyebrow:

1 Like

Finally, I’ve migrated from Hassio addon to Docker container. It seems I can’t live without Rhasspy :grin:

@Sikk, if you are interested It took 15 minutes… Just copy your old profile folder /usr/share/hassio/share/rhasspy to the host $HOME/.config/rhasspy

Also for custom .asoundrc file, you need to have it somewhere… I copied it to $HOME/.config/rhasspy/asound.conf

So my Docker installation command looks like this:

docker run -d -p 12101:12101 \
      --restart unless-stopped \
      -v "$HOME/.config/rhasspy/profiles:/profiles" \
      -v "$HOME/.config/rhasspy/asound.conf:/root/.asoundrc" \
      --device /dev/snd:/dev/snd \
      synesthesiam/rhasspy-server:latest \
      --user-profiles /profiles \
      --profile en

After rhasspy started, you may need to set HA URL and token in settings, and retrain the profile. That’s all :nerd_face:


Uh oh. I’ve stayed away from installing PulseAudio purposefully up until now. sigh

Hey @frkosThanks for preparing everything - made the switch without any problems too :slight_smile:
Just had to change the path to the wake/error sounds, and adding the ha url/ access token.

Now it’s working like before :slight_smile:

Hey again,
Now i have another problem.

Sound output suddelny stopped working.

Seems like the hassio_audio container is occupying the device.

If i stop the container - its working again until the supervisor is restarting it again.

@frkos everything still working with your setup?

edit: looks like there were some recent changes to that audio container

Hey @Sikk

I’ve decided to test new Rhasspy… and found that sound is not working.
Thanks, you tell me what the problem is :wink: I confirm if I stop HA audio container, I have aplay working again, in other case I see aplay: main:828: audio open error: Device or resource busy

Looks like we have to wait when this bug will be fixed from HA side

In the meantime we could try to downgrade the hassio_audio container to version 8 - But i’m new to docker and portainer - and i’m sure i will break stuff if i try it :smiley:

No, don’t do anything with HA docker containers =)
Do you have ssh addon installed? you can login right to the hassio CLI, and there you can run
ha audio update --version 8
I’ve tested it right now and it works… but I’m not sure for how long =)

Can confirm it’s working :slight_smile:

Wish i had a spare Pi i could run Rhasspy on, so HA doesnt break stuff all the time :slight_smile:

1 Like

In version 9

load-module module-suspend-on-idle

got changed to

load-module module-always-sink

I changed this back, using the ssh addon with

pactl load-module module-suspend-on-idle

and it seems to work. Still have to test, if it survives a reboot :slight_smile:

I’ve tried this, but for me it doesn’t work after reboot… I think I will create automation to run this command every time HA starts

There is a newer update of HA (106.6) available. Haven’t tested fully, but at first sight this seems to have fixed this issue for me. Hassio in Docker, Rhasspy in venv on same machine.

I have the same problem and Home Assistant version 0.107.7 running.

hass.io’s Audio Container prevents Rhasspy (and Snips for me) from playing audios.

When I stop hassio_audio, it restarts a few seconds later.

Hey @Pittermaennchen

Check this thread. There is hassio addon fixing this issue. But I haven’t tried it yet

Thank you @frkos!

That worked for me! I installed the hass.io-Addon OPHoperHPO posted in the thread you mentioned. It does the same as @Sikk suggested.

I use the addon that was linked there but it stopped working when supervisor updated itself a few days ago. Since then sound works (sometimes, after I manually start the addon) but nothing will free up my mic. The other workaround with the retagging of an older audio image also undoes itself after a while (not connected to any restarts, just some random checks from supervisor)