Hass.io + Rhasspy addon install with de Profile


first, Rhasspy is amazing. I love it.

I’am running Homeassistant as a virtual machine inside a Proxmox Server on Nuc8i3 Machine.
I already have installed Rhasspy(2.5.11) as Homeassistant Addon, so far so good.

But it is installed as English profile (en). And I am wondering if I could improve things, I would be able to install or choose German instead (en).

I know when useing Docker i could write the “de” into the run command as parameter.

But I haven’t found a way to tell homeassistant to install Rhasspy with the German profile. Is it possible? Does this even matter?

@synesthesiam is rightfully proud of Rhasspy supporting so many languages … though being an English speaker in Australia i personally don’t have a need for them.

There are plenty of references to Language in the Rhasspy Documentation, particularly the “Profiles” section.

I suggest however that you start with the “Rhasspy Assistant” Home Assistant Add-on. Go to the “Configuration” tab and I guess the second entry is what you’re looking for.
Try changing to “de” and restart Rhasspy

Thanks, that did it.

I tried this before… maybe i forgot to hit the save button or something.
Well it works now^^


I’m also trying to change it to “de”, but even after restarting, the profile in the web-interface stays “en”.
This prevents my speech2text from working correctly as it doesn’t understand the german words.

Any idea what I could do?

I’ve thought about gaining access to hassio (outside of docker) to look at the way it starts the rhasspy-container and maybe altering some files as a workaround, but that seems sketch.

Are you sure you hit the right save button? Thats what I did wrong the first time.
Every section has its on save button, Options, Network and Audio, I only clicked the last one that time^^

It’s been like this for weeks and it’s there when I go back to it in the settings. that should be saved correctly. I’ve also changed it back and forth a lot for debugging, but it doesn’t work.
Here is my yaml for that section of the config:

profile_dir: /share/rhasspy/profiles
profile_name: de
ssl: false
certfile: cert
keyfile: key
asoundrc: ""
http_root: ""

It’s the only thing holding my project back.

I finally fixed it! :slight_smile:

In case anyone else gets stuck on this, here’s how I fixed it:

  • I installed the SSH & Web Terminal addon and disabled protection mode before I started it to gain full access to hassio.
  • I stopped the rhasspy-addon
  • Then I used the Terminal to delete my rhasspy-profiles like this: rm -r /share/rhasspy/profiles/*
  • After that I started the addon again and it had the right profile.

My settings were gone, but at least I’m not stuck anymore.