Devices not showing in drop down menu

When I want to add a speaker or microphone to miy Rhasspy add-on in Home Assistant the devices won’t show up in the drop down menu. When I go in the settings of my HA and then to hardware these devices are visible. I tried it on a raspberry 3b+ (main setup) and I just installed HA on a VM (new setup). On both installs it won’t show up in Rhaspy junior or the advanced version. I tried it with:
Anker PowerConf S330
Kaysuda USB Speakerphone Microfoon
Trust USB microphone
All 3 devices won’t show up in the Rhaspy config but do show up on the hardware page of HA. I saw a guy on YouTube using the Anker S330 so that one should work. Am I missing something?

hey I’m having the same issue tried using the s330. I can see it show up in the output but not the input

Same as you - any update on this issue?

Are you using HAOS or Supervised ? These put Home Assistant and Rhasspy in separate Docker containers - which can provide different access to the hardware.

I use Raspberry Pi and reSpeaker HATs (which require a driver installed) and have not done the Docker learning curve … so my audio hardware was not visible. I went with Rhasspy’s base + Satellite configuration

I’m using KVM/Proxmox.qcow2 version on a VM on Proxmox.
I installed Rhasspy within Home Assistant via the rhasspy repository.

Have returned the S330, waiting on receiving a Jabra unit to see how that preforms.