Cannot trigger wake word

Hi. I have Rhasspy running on an old laptop (lubuntu 19.10) and a bluetooth speaker/microphone. When using “tap to record” it recognises what i am saying, but i have not managed to get the wake word to work.

After trying it for a while, i also switched to snowboy and downloaded jarvil.umdl. Added 2 values under sensitivity (0.5, 0.5) because it gave an error otherwise. Not really sure on this one if the wake word is just “jarvis” or “okay jarvis” or “hey jarvis” but i tried them all with no success either. I hit the ‘train’ button after any change in the wake word settings.

Also looked at CPU usage + logs while speaking the wake work, and didn’t notice anything, so i am pretty sure it is not detecting it (not sure if it gives audio feedback once it starts listening so used that as a sanity check).

Also tried with build-in microphone and same thing. Am i missing a step?

Hi @FlorinAcsinte what version do you use? 2.5pre?

Running 2.4.20.
Installed it today via Virtual Environment because docker would not see microphone/speakers.

I have similar issue, but with 2.5pre… so I guess it’s not related.
But after useng Wake button if you hit Play button, do you hear your voice?

Have you tried playing around with sensitivities of the wakeword? I haven’t played around with wakewords much but somewhere in this forum are older threads where ppl had to adjust some values to get it to work. Just try hitting the search function with something like wakeword or snowboy and skim over what you find until you find something mentioning values or try playing around with sensitivity and threshold for a bit.

This looks like it might be worth a read:

@frkos hitting the ‘wake’ button seems to work. It makes a “beep” sound and does interpret my voice.

@Daenara thanks, i will try playing around with that!

Later Edit: @Daenara tried using different sensibilities (low, high) and played around with “Apply Frontend”, no success.
Tried using recommended settings for jarvis, but without success :

resources/models/jarvis.umdl : Universal model for the hotword “Jarvis” ( It has two different models for the hotword Jarvis, so you have to use two sensitivites. Set sensitivities to “0.8,0.80” and ApplyFrontend to true.

so it’s different issue… maybe try to use standard “snowboy” hotword?

I did try it, no success.