Alsa not working when triggered from RHASSPY on Home Assistant OS (RASPI 3 and 4)

Hi all,

I already spend some hours finding a solution but unfortunately, I was not successful. So hopefully you can help me:
I’m not able to get audio output working via Alsa. I always get the following error:

AudioServerException: Command ‘[‘aplay’, ‘-q’, ‘-t’, ‘wav’]’ returned non-zero exit status 1.

When I run “aplay -q -t wav file_example_WAV_1MG.wav” via SSH everything works like a charm.
I did also try to use the “local command” option, but I get the same error.

I use the following setup:
Rhasspy addon: 2.5.9
HA Core: core-2021.1.5
HA Supervisor: supervisor-2021.01.7
Additionally I tried it on two different Raspis:

Hardware : BCM2711
Revision : b03111
Model : Raspberry Pi 4 Model B Rev 1.1

Hardware : BCM2835
Revision : a02082
Model : Raspberry Pi 3 Model B Rev 1.2

Furthermore I can see the following in the logs:

[ERROR:2021-02-03 19:38:09,961] rhasspyserver_hermes: Command '['aplay', '-q', '-t', 'wav']' returned non-zero exit status 1.
Traceback (most recent call last):
  File "/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/quart/", line 1821, in full_dispatch_request
    result = await self.dispatch_request(request_context)
  File "/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/quart/", line 1869, in dispatch_request
    return await handler(**request_.view_args)
  File "/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/", line 1700, in api_text_to_speech
    results = await asyncio.gather(*aws)
  File "/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/", line 1686, in speak
  File "/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/", line 614, in speak_sentence
    raise AudioServerException(play_response.error)
rhasspyserver_hermes.AudioServerException: Command '['aplay', '-q', '-t', 'wav']' returned non-zero exit status 1.
[ERROR:2021-02-03 19:38:09,960] rhasspyserver_hermes: AudioPlayError(error="Command '['aplay', '-q', '-t', 'wav']' returned non-zero exit status 1.", site_id='default', context='92f2438b-00f5-47a4-8e68-b9c020d0cb12', session_id='92f2438b-00f5-47a4-8e68-b9c020d0cb12')

Thank you all in advance!

Old post I know… not sure if you ever got this fixed.
I recently started playing with the idea of mixing two systems on my speakers.
I found that after another system used the speaker, I got this error.

So my guess and question would be… do you have something else on this system using the speakers?
If so, I expect this error is really a “device in use” or “busy” error…

Just a thought.