Wrong URL web interface

When I start rhasspy on my home assistant and enter the web interface, I changed the default url and typed a wrong one, and I can’t access the web interface anymore.
I would need to know in which file I should change it back and put 192.168.1.100

I tried uninstalling and reinstalling but apparently the file stays on my host and does not disappear when uninstalling, and therefore loads it again with the new installation.

The installation is done in docker

My base station (http://192.168.1.88) is running Home Assistant OS with Rhasspy Assistant add-on in a docker container. Its web interface is at http://192.168.1.88:12101

I don’t understand what file you think you need to change…

I mean that from the home assistant app I click OPEN THE WEB INTERFACE and it automatically tries to access with the name of my instance followed by :12101 and it gives an error because I have not configured the SSL certificates.

I think that at some point I modified something and try to access by that means.

And I couldn’t access it either through the IP 192.168.1.100:12101, but since a few days ago I can access it this way.

It is happening again and I cannot access with the IP 192.168.1.100:12101

I am not using SSL (it is one of the learning curves I have avoided so far), and I don’t think it is required for Rhasspy. There is a section in the HA Rhasspy Assistant’s Configuration tab for “SSL”, and again at the bottom of the Rhasspy web interface page for “Certificates”, but this is optional.

I do recall that the HA Mosquitto add-on defaults to SSL. It doesn’t help that the add-on initially reports that there is no user configuration, but if you go back later (possibly after a restart) to the MQTT add-on, Configuration tab, you can turn off “.Require Certificate”.

Have you checked for error messages in the “Log” tab of the HA Rhasspy Assistant page ? There are a mountain of DEBUG messages which can make finding any errors tedious.

Where did you change the default url?

Hugh, I don’t believe any change to URL was needed; the error message because OP had not configured the SSL certificates - but SSL is not required.

If I click on OPEN WEB INTERFACE it keeps giving me an error because it keeps going to the web address (I don’t know where I changed it), but what I do is put 192.168.1.100:12101 and enter the interface.

As Donburch says, I had the SSL certificates marked and I don’t have them, and that’s why I couldn’t enter with my IP.