Wrong pronunciation of the word rhasspy

I’m using Rhasspy 2.5.0 (with dutch as language). When training Rhasspy for my sentences, it
tells me it doubts the pronunciation of the word Rhasspy, it suggests the following:
rhasspy r A s p i
When I make the system pronounce the pĥonemes “r A s p i”,
it pronounces it as r A s t i, the p is pronounced as a t. Is this a bug? How can I make Rhasspy pronounce its own name correctly?

kind regards,

So in the words tab of your rhasspy instance you can set the pronounciation for any word.
You can see a list of all phonemes here in the whitepaper.

If you type in the word you want to set, it will guess some different pronunciations to which you can listen then and decide by pressing the Add button.
If you really want to, you can play around with the phonemes yourself and make your own creation. :wink:

Feel free to share your final result with us once you found THE ONE

I tried r A s p i which results in the pronounciation: rasti
I also tried also r A s P i which results in the pronounciation: razi (z pronounced as in zulu)
The system seems for some reason refuse to pronounce the p as a p
Any idea why?

kind regards,

Maybe try R AH S P IY
And play around with the A a bit… depending on which pronunciation you prefer.

Phoneme Word Pronunciation
AA odd AA D
AE at AE T
AH hut HH AH T
AO ought AO T
AW cow K AW
AY hide HH AY D

When trying R AH S P IY I hear something like ksh (no vowels nor diphthongs are pronounced!). I think this behavior is a consequence of using Rhasspy nl i.e. with Dutch language recognition in combination with Kaldi.This combination seems to lack the phonemes necessary to pronounce Rhasspy…
Is it possible to edit the Kaldi phonemes list?

I just listened to dutch phonemes and you are right. There is no “aggressive” P. Very interesting in my opinion. :thinking:
Did you resolve the issue by tinkering with the TTS or kaldi?
Maybe it would be possible to have different TTS clients running for languages. That sounds like a nice enhancement. (in a simple way at least)

I’ll look further into it (and hope others will do so too). But maybe it’s better to follow the more general thread considering this issue:

As Koan pointed out, it is not Kaldi but the TTS, I guess it is Espeak, but it is certainly a bug