When using other TTS system other than Espeak, the play back is super fast

Hello. A total n00b here. When I use espeak as my tts, the play back is fine. When I choose something else ie PicoTTS the play back is insanely fast and I cannot make out any words.

I installed the pico2wave utils and such on the rpi and the generate a wav file via the command line and transferred that wav file to my personal laptop with VLC and it plays correctly, but when I try to use the TTS within Rhasspy web UI it is super fast, so fast that you can’t hear any words just high pitched gibberish as if someone was fast forwarding the audio.

How can I debug this/fix this?

Thank you!

I think I’m looking for the same solution - using NanoTTS on 2.5.4 and was hoping to find a setting to adjust the playback speed. NanoTTS has it in the CLI but I don’t think that I can set it from the Rhasspy GUI.

If this isn’t something available yet, I might submit a feature request to have it added. It might be difficult though if each TTS piece has a different way of doing it… maybe just a field where you can manually enter the CLI commands…

Cheers!
DeadEnd

This looks like an ALSA sample rate issue. Your WAV file is 16KHz but is probably played on a 44.1KHz or 48KHz output. Try to prefer plughw: instead of hw: audio output devices.

mmhmm but then how does espeak work fine but nothing else works…is there away to set the play back rate correctly?

I set the default device as plughw, if i just use hw. no audio is played at all.

I guess the question is how did people set up TTS with things other than eSpeak.

edit: I am using a Jabra SPEAK 510 USB if that is of any relevance.