Usermod: user 'pi does not exist error

Brand new Rhasspy user here. Trying to follow the tutorial and got docker installed but when I try to add the pi user to the docker group with this command

$ sudo usermod -aG docker pi

I get this:

usermod: user ‘pi’ does not exist

I have searched all over the internet and haven’t figured it out yet. I using a RPi 3B+. TIA for your help.

I tried running the Rhasspy install with sudo docker pull rhasspy/rhasspy and it installed but now it won’t run. I get:
docker: unknown server OS: .
See ‘docker run --help’ .

When I type sudo hostname -I
I get 2 IP addresses
Is the second one the Rhasspy IP address?

If I type docker image ls -a I get:
permission denied while trying to conneto the Docker daemon sockat at unix:///var/run/docker.sock: Get “http://%2Fvar%2Fdocker.sock/v1.24/images/json?all-1”: dial unix /var/run/docker.sock: connet: permission denied

I also get the same message with a different http location when I type docker container ls -a

I used the debian installation method and it worked much better. I have Rhasspy installed and it runs but struggling to get the web UI to open on my laptop. I just get this site can’t be reached. It could be because I am connected to my work guest wifi. I may have to see if I can get connected to our internal wifi or take it home and try my home wifi.

Personally I avoided docker, but wonder if your first two posts may have been commands executed at the OS level or in the docker container ?

Anything connected to a Guest wi-fi should be considered a possible security threat, so (by default) are only allowed to access internet, and not allowed to connect to official work machines or to each other.

“pi” is the login user name that you typically use when logging in via SSH for example. If you are in the shell environment, your command prompt should be something like pi@pi4b. pi is the current login and pi4b is what your pi is named. If you used the new raspberry pi software to create your micro SD card, it gave you the option to set a user and password. By no means an expert, but I’m a week or two ahead of you and that has worked for me. Docker is a pain at first, but after you catch on to the basics it is very workable. So far, I have developed four custom apps/skills to control my stereo, home automation, etc. Painful at first.

Also your stated usermod command is not exactly per the Rhasspy docker install instructions. -a -G vs -aG . Not a Linux expert. Don’t know if this matters.

I recall having to reboot the pi after executing the usermod command before the command takes effect.