USB Microphone detected but exceptions raised during use?

I have a ACER Aspire M3970 running Debian 10. I have a Plantronics 628 headset.

Running rhasspy 2.5.11 under docker with the example rhasspy document site. That is, default and unmodified, being:

$ docker run -d -p 12101:12101 \
      --name rhasspy \
      --restart unless-stopped \
      -v "$HOME/.config/rhasspy/profiles:/profiles" \
      -v "/etc/localtime:/etc/localtime:ro" \
      --device /dev/snd:/dev/snd \
      rhasspy/rhasspy \
      --user-profiles /profiles \
      --profile en

Profile for my setup is:

    "dialogue": {
        "system": "rhasspy"
    "intent": {
        "system": "fsticuffs"
    "microphone": {
        "system": "pyaudio"
    "sounds": {
        "system": "aplay"
    "speech_to_text": {
        "system": "kaldi"
    "text_to_speech": {
        "system": "nanotts"
    "wake": {
        "system": "porcupine"

rhasspy comes up fine, but when I try “wake up” on the home page, the software reports “no intent recognised”?

I use the utterance “what time is it” from the default list that comes with the install.

Poking around, and maybe a red herring, I tried selecting the Plantronics 628 on the pyaudio page. When I hit “Test” the console spewed up up copious error messages and then the Plantronics is unselected.

Is there a “missing” step to setting up a USB mic with rhasspy?