Unable to use porcupine jarvis hotword on Respeaker core v2


I’m trying to use Porcupine with the default “jarvis” model on a Respeaker core v2

Here is my Rhasspy config:

    "wake": {
        "porcupine": {
            "keyword_path": "jarvis_raspberry-pi.ppn",
            "udp_audio": ""
        "satellite_site_ids": "maison.rhasspysejour",
        "system": "porcupine"

My Rhasspy profile is in: “/etc/rhasspy/profiles/fr/profile.json”

I downloaded the jarvis model and placed the .ppn file into my Rhasspy pforile dir

mkdir /etc/rhasspy/profiles/fr/porcupine
cd /etc/rhasspy/profiles/fr/porcupine
wget https://github.com/Picovoice/porcupine/raw/master/resources/keyword_files/raspberry-pi/jarvis_raspberry-pi.ppn
file jarvis_raspberry-pi.ppn
jarvis_raspberry-pi.ppn: data

Restarted Rhasspy, sayed “jarvis” several times with different volume; but the wakeword never gets detected :frowning:
When I look at the Rhasspy logs; I can’t see any error. Only normal startup logs.

The Respeaker core v2 architecture is “armv7l”. Can it be the root cause of my problem ?

NB: the exact same setup works fine with a custom Snowboy wakeword and also with a custom Raven wakeword

Is someone able to help me ?
Thank you very much
Best regards

Hi guys,
Someone here to help me ?


I’m somewhat new to this so this may not be a help but I noticed your profile path is fr for French? If so, is it maybe an issue with the language of the jarvis model? I see they have some french specific models here: porcupine/resources/keyword_files_fr/raspberry-pi at master · Picovoice/porcupine · GitHub, maybe try one of those? Could just be the the language model has EN hard-coded in it somehow?

I’m using porcupine with jarvis hotword.
I did not download it because I could choose it in the list.
Please try this:
1a.) check the mic
Click on WAKE UP link on the start page and try to send commands
1.b) choose other build in Wake word
if this does not work:
2a.) delete UDP Audio (Input) in Settings-> Wake Word
If this does not work:
2b.) change Sensitivity for JARVIS to 0.5 in Settings-> Wake Word and try again


Hi all,
Thank you so much for your tips.
I cannot test it right now but I’ll keep you up to date about my progresses.
Best regards

Hi all,
I did some tests and unfortunately it didn’t work.

Checked mic with “wake-up” from Rhasspy → OK (not surprising because it works with another wakeword like Raven)
Following the advice of @JoeSherman I tried several french wakewords; but it also didn’t work(no wakeup from Rhasspy and nothing in the logs :frowning: )
Wakewords I tried:

(The Respeaker Core v2 I’m using seems to be an ARM Cortex A7)

I did the tests with and without the UDP port configuration on the Rhasspy wakeword system; with no improvment)

I think my best chance would be to have some tips from someone who is already using Porcupine on a Respeaker core v2 :slight_smile: (I’m quite sure the problem is related to the ARM Cortex A7 architecture)

I will try to build a custom French hotword from Picovoice console for an ARM Cortex M platform.
NB: For the moment I cannot do because I already trained 3/3 custom wakewords; so I will have to wait a little.

Thanks a lot again for your help and stay tuned :wink:

Best regards

Hi all,
Bad news here :frowning:
I explained this problem on Porcupine GitHub and got the following answer:
“we don’t support this platform. we do support respeaker microphone arrays from respeaker.”

So it seems I will have to search for an alternative KWS system.

Thank you anyway for your help.

Best regards