Trying to set up Base Server and can't save settings

I’m failing at the first hurdle.
I’ve got a Proxmox Server running a Debian LXC container running Docker that I’m aiming to use as the base station.
I’ve used the following compose script:

    image: "rhasspy/rhasspy"
    container_name: rhasspy
    restart: unless-stopped
        - "/optdocker/rhasspy/profiles:/profiles"
        - "/etc/localtime:/etc/localtime:ro"
        - "12101:12101"
    command: --user-profiles /profiles --profile en

(Note this box lives in the Loft and there will be no audio so I don’t have a devices section)
The container is running as root and the path /opt/docker/rhasspy is owned by root with 755 permissions.

Everything seems to start up just fine and the web UI is reachable, however when I go into the settings page and try and do things like update the site ID or change to an external MQTT server the Saving Profile banner appears at the top and just sits there. Eventually there is a red banner at the bottom of the page that says error, but nothing that helps me work out what the error is.

The only thing interesting I see in the logs are BadRequest(400) errors :

[ERROR:2023-01-05 15:27:38,924] rhasspyserver_hermes: BadRequest(400)
Traceback (most recent call last):
  File "/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/quart/", line 1821, in full_dispatch_request
     result = await self.dispatch_request(request_context)
  File "/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/quart/", line 1863, in dispatch_request
     raise request_.routing_exception
quart.exceptions.BadRequest: BadRequest(400)

But they don’t seem to be directly related to the request to save the profile, appearing in the logs just after a restart but before I’ve tried to save.

I assume I’ve done something wrong and this has probably been covered but I just can’t seem to find any info that helps. Any pointers ?

hmmm … went away for 2 hours … came back an it worked … really strange

update … ok vpn was the issue … turned it off and it worked.