Training fails every-time on Rhasspy


I’ve been facing problem with training sentence.ini file even if I’ve one line sentence. It does show me save sentence file message, then it starts to train but eventually it gives me Time out error.
I would be happy if anyone can point me out what to do.

System info:
Rapsberry Pi 3B+ running Raspbian Buster
Rhasspy 2.5.9 on Docker

Kindly see log file:

rhasspyserver_hermes: Publishing 228 bytes(s) to rhasspy/nlu/default/train
rhasspyserver_hermes: -> NluTrain
rhasspyserver_hermes: Publishing 228 bytes(s) to rhasspy/asr/default/train
rhasspyserver_hermes: -> AsrTrain
rhasspyserver_hermes: Subscribed to rhasspy/nlu/default/trainSuccess
rhasspyserver_hermes: Subscribed to rhasspy/asr/default/trainSuccess
rhasspyserver_hermes: Finished writing /profiles/en/intent_graph.pickle.gz
rhasspyserver_hermes: Writing /profiles/en/intent_graph.pickle.gz
rhasspynlu.ini_jsgf: Loaded ini file
rhasspyserver_hermes: Generating intent graph
rhasspyserver_hermes: Loading sentences from [PosixPath(’/profiles/en/sentences.ini’)]
rhasspyserver_hermes: Starting training
rhasspyserver_hermes: Writing /profiles/en/sentences.ini

Traceback (most recent call last):
File “/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/quart/”, line 1821, in full_dispatch_request
result = await self.dispatch_request(request_context)
File “/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/quart/”, line 1869, in dispatch_request
return await handler(**request_.view_args)
File “/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/”, line 1321, in api_train
result = await core.train()
File “/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/”, line 461, in train
File “/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/”, line 971, in publish_wait
result_awaitable, timeout=timeout_seconds
File “/usr/local/lib/python3.7/asyncio/”, line 449, in wait_for
raise futures.TimeoutError()

Thanks in advace.

Do you have both a speech and intent recognition service selected in your settings? Something like Kaldi (speech) and fsticuffs (intent)?

Thank you so much for your response.

Yes, I’ve set all those parameters.

Please have a look at my profile:

“dialogue”: {
“system”: “rhasspy”
“intent”: {
“system”: “fsticuffs”
“microphone”: {
“system”: “arecord”
“sounds”: {
“system”: “aplay”
“speech_to_text”: {
“system”: “kaldi”
“text_to_speech”: {
“system”: “nanotts”
“wake”: {
“porcupine”: {
“keyword_path”: “”,
“sensitivity”: “0.6”
“system”: “porcupine”

Do you think I need to change anything here?

Thanks again.

That looks fine. What does your sentences.ini file look like?

Right now I’ve one intent only due to training issue initially I had bunch of sentences.

sentences.ini file looks like


Turn (on | off) {state} [the] (left | right) {motor} motor
Turn (on | off) {state} [the] both {motor} motors

Today itself I tried to train but no improvement.

Changed current Rpi to new one. It solved my problem.