[SOLVED] Newbie fresh installation of 2.4.16 but no input or output (although following instructions on matrix-labs)


I’m a total Rhasspy noob although I did have snips.ai running on a Rpi 3B. But as snips-ai is shutting down I wanted to try out Rhasspy but I have a very hard time getting it to work on matrix voice microphone.

So I first stopped & disabled all snips-ai services to release microphone & output device (checked with “sam status”). Then I followed the instructions at matrix-labs to make Rhasspy work with matrixio microphone over here: https://www.hackster.io/matrix-labs/rhasspy-voice-assistant-on-matrix-voice-and-matrix-creator-97f92e

Although installation seemed to work perfectly fine I have 2 issues.

  • rhasspy doesn’t detect the ‘porcupine’ hot word at all (probably microphone doesn’t work), the log stays completely empty
  • rhasspy also doesn’t output sound to my front speaker although aplay works perfectly fine. When I go to the “Speech” test and enter something into the text field and click on “Speak” output device stays completely silent. I tried different cards but I also don’t know which one would be correct as there is “dmix, dsnoop, plughw, front, surround”. I aplay it shows as

card 2: Device [USB2.0 Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

For the microphone problem, what I noticed is that when I select matriox hw card in the alsa-settings that after Rhasspy restart an I go back to the microphone settings it says default-device. Is this normal behaviour or should it keep what was selected?

Any help here is greatly appreciated.

I finally found the correct alsa output device, so I at least get audio output. The the microphone problem still persists. Porcupine hotword is not detected. Should I try different wake word system?

Hi @marcelser
When you try to run arecord from Rhasspy docker container, do you hear your voice well?

Also does “Wake” button work for you?

turns out that arecord reported “arecord: main:788: audio open error: Device or resource busy”. So finally I noticed that snips-audio-server was running again (for whatever reason cause I stopped it and checked with sam status). So I stopped it again and now the microphone is working. Having a hard time though now using pocketsphing though as this really breaks even after re-training and restarting. You can also see the errors in the log, but I guess I will put this thread to solved and report this in the 2.4.16 new release thread.

1 Like

marcelser. You are not alone !
I had exactly the same problems as you.
I have spent hours (I know nothing about programming) getting mine working, but I got there.
I ended up using the ‘plughw’ option for microphone input from my Respeaker 4 mic array V2.
For my wake word, I had to use a spare Pi zero with snips wakeword over mqtt, to get wake word working.
I don’t use Docker, I use the Python Environment.
I am sure that there are so many good options with Rhasspy, we all will be happy eventually.
Keep on 'Rhassping ! ’