Slots not being saved on 2.5.5


I am trying to save a new slot in the GUI but it doesn’t save it nor the logs present any error.
If I refresh the page the slot is gone.
I tried recreating the slots folder beforehand and even chmod 777 but no file is saved anyhow.

Running rhasspy on Docker


Not sure what is causing your problem. I just tested if i can create new slots with 2.5.5 and i got no problems. Here are a few questions i have to find out what your problem could be.

After pressing the save slots button nothing happens for you?
What exactly are you doing to create and save the slot?
Are you using any , in your slots ?


Thanks for replying!

  • Procedure followed:
  1. Click New Slot
  2. Enter the name and click “New Slot” (at this time the slot file should already appear on /slots on the rhasspy folder right? it doesn’t do nothing)
  3. insert some dummy test and click “Save Slots” nothing happens


any tips or anyone experienced this ? thanks

I’ve just tried this out (2.55 on Docker), and it works like expected.

If you manually create a slot (a text file without file extension in the slots directory in your profile, does the GUI pick it up?

Hi @mattsches . Yes I have tried creating it manually and it doesn’t pick it up. Could this be a permissions issue somehow?

This sounds like Rhasspy is using a different profile directory, or you’ve set something different for speech_to_text.slots_dir (almost no one does).

What are you passing to docker run for a profile directory and for --user-profiles?

using like this : docker run -d -p 12101:12101 --add-host xxxx:192.168.1.xx --name rhasspy --restart unless-stopped -v “$HOME/.config/rhasspy/profiles:/profiles” -v “/etc/localtime:/etc/localtime:ro” -v “/etc/asound.conf:/etc/asound.conf” --device /dev/snd:/dev/snd rhasspy/rhasspy --user-profiles /profiles --profile en