Share here your Respeaker Mic Array 2.0 configuration

Hi, I replaced the Respeaker 2 mic Array with the Respeaker Mic Array 2.0 that would be Better in terms of performance (noise cancellation etc.).
It worked outofthebox so I tried the same configuration that used with 1.0 microphone version with snowboy and “Jarvis” as wake word.
It doesn’t work 10/10 times, I need to speak really near the microphone to obtain the wake Word.
If I activate the wake manually from the web ui It understand perfectly my words and It triggers the intent.

Does anyone has experience with this microphone and snowboy? Are there anywhere parameters that I can try to change?

Thanks you

1 Like

From a Linux command prompt,try the ALSA program alsamixer. Your MIC input should appear, and you can boost the sensitivity using the up and down arrows. Depending on your particular hardware, you may need to hit F5 for all devices, and then use the left/right arrows to highlight the MIC input.

Alsamixer shows me “This sound device does not have any controls”
image

Anyway I see that someone had the same problems with snowboy and respeaker v2.0

Seeed offers firmware with different Input gains. I’m using the one with +12db gain and that’s working pretty well

what umld are you using with snowboy? can you post your configuration?
I’m trying “jarvis” with 0.6 sensivity, that seems to work well with default 6_channell firmware.

"wake": {
    "snowboy": {
        "apply_frontend": true,
        "model": "snowboy/jarvis.umdl",
        "sensitivity": "0.6,0.6"
    },
    "system": "snowboy"
}

UPDATE: it seems to be a problem with webrtcvad times configuration…
If I use “tap to record” button from webui the intent recognition is ok.
Otherwise if I use snowboy wake word, the command is not recognized properly…probably the registration after wake starts too early or too late…

OK for snowboy.
The main issue now it’s that Respeaker V2.0 notice my tv audio as my voice…actually respeaker v1.0 has better performance than v2…

EDIT:
I changed the title becouse would be interesting to share here the configuration of our Respeaker v2.0 microphone. I have the feeling that it is a very powerful microphone but that one does not know how to exploit its potential

For those interested I discover that Pocketsphinx does not work properly with 6-channel firmwares, as you can read there.

Probably it supports only 1 channel recorded for ASR.
I tried 1 channel firmwares and finally it works as expected.

1 Like

Did you ever find any setting for webrtcvad or otherwise to improve the recognition quality? I’m seeing exactly the same thing where recognition from kaldi is near perfect when using the browser to record input, but using the ReSpeaker mic array or a Jabra 510 results in a really big drop in accuracy (mostly incorrect).

Also, is there an easy way to retain or otherwise listen to the recorded files to help troubleshoot? I’d like to make sure the input gain or power supply noise isn’t something that’s causing the issues (I’ve tried all three 1 channel firmwares with the same results).

//TB

Sorry for the delay…I am not using kaldi and yes I have the same problems…the recognition Is very pour. I tried with different firmwares but without results…Do you have updates?

Haven’t had time to troubleshoot further. Was going to test the following next: