Setting up a local Development Environment Linux Mint

Hey there,
I’m really fascinated by this project and want to experiment a little with it.
So for the last week i have been trying to set up a local development version on my Laptop running Linux Mint Sylvia based on the latest Rhasspy from GitHub. I’ve tried following the virtual environment installation guide from the wiki however with no success.
My plan is to test the limits of the pi hardware wise and experiment a little with constant listening…

What would be the steps if i wanted to set up a development environment on my Linux Mint Sylvia, so I could then create docker-images which i could deploy and run on my pi?
Thanks in Advance :slight_smile:

What exactly is failing? What error message do you get? The Python virtual environment works on my Ubuntu 19.10 system, so in Linux Mint it shouldn’t be that different.


While executing the build dependencys it stops while trying to install flit-core with wheels
Running install for flit-core: started
Running install for flit-core: finished with status ‘error’
[…] ModuleNotFoundError: No module named ‘setuptools’
However setuptools is installed.
But for building a docker image I don’t need to build the venv anyways or do I?

I thought I had that fixed last week:

Can you do a git pull to use the latest Rhasspy source and try again?

I’m not sure how @synesthesiam builds the Docker images, I haven’t done this yet, but you shouldn’t need a venv for that.

1 Like

I pulled from git and got the venv running, thanks for the hint :slight_smile: .

However while running the dependency script I still get the error message: rhasspy-nlu 0.1.3 has requirement networkx==2.3, but you’ll have networkx 2.4 which is incompatible.
In the requirements.txt however it is stated that any version >= 2.0 will do.
Is that intentional or should it be changed to ==2.3 to install the correct version while running ./

I’m not sure. I got that message too, but Rhasspy does work, so I guess it’s just a warning.

I changed the version number in the requirements.txt like mentioned above and got rid of the error message. Just in case so there won’t be any hidden complications…^^