Setting Kaldi on RPI 3B+ in FR profile

Hi there,

I’m trying to set up kaldi running on my RPI3B+ setup, on an FR profile.

I’ve read some thread here about enhances fr profile, but I’m currently not able to download base files.

In original set up I just can’t enable kaldi :

Do speech recognition with kaldi on this device
Not compatible with this profile

So I forced Kaldi in profile.json by adding :
In “speech-to-text” setting

After rhasspy restart it ask :

Some files must be downloaded for your selected profile (fr).
Rhasspy will not work correctly until these files are downloaded.
0: “speech_to_text.system”
1: “kaldi”

That’s sound great! that"s the folder I miss to dl FR enhanced files.

=> But few seconds after hitting download button -> error :

Compressed file ended before the end-of-stream marker was reached

I do not know what I can do with

So I’ve tried to copy kaldi-generic-fr-tdnn_250-r20190930.tar.xz to a kaldi folder in my profile and point to that folder in the json, but event if it succeed in training, it doesn’t work at all.

What could I do?

[note] My setup in my profile!

Many thanks


Hi there,
After a WAF rebuikding I’m trying to wake up my rhasspy device.

I’ve update to :latest (2.4.18 at this time).

I’ve still have the same issue, unable to run kaldi on my FR profile.

Any clue for setting it up?