Satellite Voice Recognition not working

The last weekens Iam trying to get Rhasspy running.
Iam aiming for an satellite / server configuration.
At the moment i have an rhassbery pi running home assistant, hermes mqtt(mosquito) and rhasspy master.
On an laptop with mic and audio output i run rhasspy satellite in an docker.

I setup both like in the documentation: rhasspy docs: server-with-satellites

Sometimes it was a little bit confusing, cause the documentation does not 100% fit the neweset version (2.5.9).

The command:
docker run -it
-v “$HOME/.config/rhasspy/profiles:/profiles”
–device /dev/snd
–profile en
–user-profiles /profiles

For example brought me some problems: some python error came up, but the console said it was running. But the webservers were not running.
So I tried the command for normal installation of rhasspy:
docker run -d -p 12101:12101
–name rhasspy
–restart unless-stopped
-v “$HOME/.config/rhasspy/profiles:/profiles”
-v “/etc/localtime:/etc/localtime:ro”
–device /dev/snd:/dev/snd
–user-profiles /profiles
–profile en

And it worked (:
But maybe that’s why I have problems.

My main problem is:
You can type text to recognize in the satellite and it detects it, custom words, which are not in satellite setences. Just in masters. So they have to communicate.
But when I say the wakeword (and it detects) nothing happens. Just after some time he times out.
In satellites console there are timout errors, but in master console theres nothing.

Do they really communicate?
Did I confiugre something wrong?

Master Config:

Satellite Config: