Satellite Setup with HTTP API


Thank you for this awesome project. I am relativly new to rhasspy - i think 2 weeks right now :wink:.
As a standalone solution - everything is working fine. But now i try to enroll satellites. (HTTP API) For this purpose I enrolled rhasspy on my home assistant server as a docker container. On a raspi 2b i enrolled rhasspy as a docker container as well.

Now my problem: Wake word an intend is working well - but the answer is not transfered back to the satellite - i opened a github issue ( But may be it is configuration issue. Can you help me.

Kind regards

I’ve followed this tutorial and everything worked as expected:

Me too - with one exception - i used the 2.5.0 and not the 2.5.0-pre

Now i checked the integration with an external MQTT. As a result - the intent is not executed at the master / server - network connectivity is there and the intend is detected - but the intend is not transferd to home assistant (as far as i can see).

Hello Again,
It took me some hours but finally I found the errors in my system (at least some of them). So it works now. For the other guys - having problems with the master / satellite setup here are my solutions / corrections.

  1. I changed the protocol from HTTP-API to MQTT - not a solution to my errors but it makes some things easier
  2. My docker-compose file for the satellite had some errors - here is my final one:
$ cat docker-compose.yml 
version: '3'
    image: rhasspy/rhasspy
    container_name: rhasspy-satellite
    restart: unless-stopped
      - 13202:13202
    privileged: true
      - "/home/pi/rhasspy/profiles:/profiles"
      - "/etc/localtime:/etc/localtime:ro"
      - "/dev/snd:/dev/snd"
    command: --user-profiles /profiles --profile de --http-port 13202 --local-mqtt-port 13183

take a look at the privilege directive - worked out some issues with my usb-microphone / speaker

  1. I changed the audio recording to arecord and entered my hardware device directly in the config file (profiles//profile.json)
microphone.arecord.device: "sysdefault:CARD=USB"
sounds.aplay.device: "sysdefault:CARD=USB"

this solved some problems with a disapearing speaker or microphone

  1. I finally understood that intend handling (the connection to home assistant) can only be made at the satellite - so I entered my home assistant credentials there (I hope Michael Hansen and the rest of the rhasspy guys will find a solution for that) - and et volià - everything works

Final words - rhasspy is the solution I have been looking for a very long time. An offline, privacys respecting voice assistant (with a direct connection to my home automation) - thanks guys for this awesome (I am German - we never say awesome!) piece of software.

Hope my descriptions above help other people to rollout rhasspy.

Stay healthy and take care