Satellite master where to put the intent handling?

I am following the satellite-master guide. Into introduction its written that the server triggers the intent handling.
But in the settings screenshot the intent handling is not mentioned, It Is disabled at both, satellite and server.

Anyway I am following the guide, I setup a satellite and a server across external MQTT broker, then the intent handling is:

  • disabled on satellite
  • homeassistant on server

At this point I speak on the satellite but the server intent handling It is not triggered.
I am aspecting that the intent handling is centralized at the server…
Does It my fault?


I use home assistant and publish events, so i put it on the satellite and it works great.

I could never get it to work on the server either but i agree, it seems like it should go there.

Well, it all depends on how you want to handle your intents. I’m using the Hermes MQTT protocol for intent handling with my own apps. So I have intent handling disabled in the settings, both on the base and the satellite, and both Rhasspy machines are using an external MQTT broker.

Then I can run my intent handling apps on whatever machine I want, because they just respond to the MQTT messages they subscribe to on the MQTT broker. In practice I run my intent handling apps on the Rhasspy base system, but when testing I run them on my laptop and I can just run them on any system with access to the MQTT broker.