RPi 3b/ ReSpeaker 2-Mics Pi Hat Configuration

I installed Rhasspy 2.4.19 using Docker on a RPi3b (Buster) with a ReSpeeker 2-Mics Pi Hat following
the instructions here. Rhasspy works with mic but not the speaker. For the Audio Playing I have selected Use aplay directly (ALSA). The Output Device dropdown shows several options but after selecting a new device (I tried all the options) , saving and restarting, Output Device shows ‘Default Device’ and no sound .
Am I missing something? What is the correct configuration for the ReSpeeker Pi Hat?

I use 2.4.18 with same hardware.
I deactivate the internal sound-card, so I only have seed2Mic entries.

/etc/asound.conf stays with original seed2Mic version
These are my profile.json entries:

  "microphone": {
        "arecord": {
            "device": "sysdefault:CARD=seeed2micvoicec"
        }, ...

    "sounds": {
        "aplay": {
            "device": "default:CARD=seeed2micvoicec"
        }, ...

I have also disabled the Raspberry Pi’s on-board audio, and then the ReSpeaker audio out is recognized by Rhasspy.

That worked, thank-you!