Rock Pi S issues with Wake words

Hi Guys,
I have an Issue with the wake words:

  • Snowboy
  • Procupine
    both do not work and running in circles.

Example Log out from Porcupine
— SNIP —
| hardware_info = [x for x in cpu_info.split(’\n’) if ‘Hardware’ in x][0]
rhasspy | IndexError: list index out of range
rhasspy | 2021-03-25 13:20:01,191 INFO exited: wake_word (exit status 1; not expected)
rhasspy | 2021-03-25 13:20:02,210 INFO spawned: ‘wake_word’ with pid 731
rhasspy | 2021-03-25 13:20:03,218 INFO success: wake_word entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
rhasspy | Traceback (most recent call last):
rhasspy | File “/usr/lib/python3.7/runpy.py”, line 193, in _run_module_as_main
rhasspy | “main”, mod_spec)
rhasspy | File “/usr/lib/python3.7/runpy.py”, line 85, in _run_code
rhasspy | exec(code, run_globals)
rhasspy | File “/usr/lib/rhasspy/rhasspy-wake-porcupine-hermes/rhasspywake_porcupine_hermes/main.py”, line 15, in
rhasspy | import pvporcupine
rhasspy | File “/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/pvporcupine/init.py”, line 13, in
rhasspy | from .util import *
rhasspy | File “/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/pvporcupine/util.py”, line 54, in
rhasspy | _PV_SYSTEM, _PV_MACHINE = _pv_platform()
rhasspy | File “/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/pvporcupine/util.py”, line 47, in _pv_platform
rhasspy | pv_machine = _pv_linux_machine(platform.machine())
rhasspy | File “/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/pvporcupine/util.py”, line 23, in _pv_linux_machine
rhasspy | hardware_info = [x for x in cpu_info.split(’\n’) if ‘Hardware’ in x][0]
rhasspy | IndexError: list index out of range
rhasspy | 2021-03-25 13:20:04,732 INFO exited: wake_word (exit status 1; not expected)
rhasspy | 2021-03-25 13:20:05,748 INFO spawned: ‘wake_word’ with pid 739
— SNIP —

Rhasspy Raven is working
I have this issue only with the Docker Image ARM 64-Bit 2.5.9
With my Pi Zeros or Intel boxes I didnt have this issue.

Some ideas whats wrong with my setup?

Br Kuumaur

Its prob not your setup its the info returned from your distro on your rockpis that is different to what Pi and Intel give.
hardware_info = [x for x in cpu_info.split(’\n’) if ‘Hardware’ in x][0]

The rockpiS is just a A35 rather than Pi A53 and would have look at shape of the array returned and what is returned in comparison.
I got that same error when I used pvporcupine on Ubuntu 20.04 when it was still fresh and think they fixed it but guess what you have does something similar.

Ok, I understand.
So the solution is to install Ubuntu on the Rock Pi S and then install Docker on Ubuntu and next install Rhasspy Docker image?

Thanks in advance

I dunno but the error is a pvporcupine one whilst it queries the hardware platform

I think I will move away from Docker Images for this project.
As much as I like Docker, I think I will move to native installation.
Thanks

I installed Rhasspy 2.5.9 on the Rock Pi S direct, without Docker in between.
I also changed from Radxa Debian to Armbian legacy.
Opening an Issue in Github.
(https://github.com/rhasspy/rhasspy/issues/206)

The Issue with the Hardware/CPU/Architecture identification is still there.
2021-04-01 19:13:13,185 INFO success: wake_word entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
Traceback (most recent call last):
File “/usr/lib/rhasspy/usr/local/lib/python3.7/runpy.py”, line 193, in _run_module_as_main
main”, mod_spec)
File “/usr/lib/rhasspy/usr/local/lib/python3.7/runpy.py”, line 85, in _run_code
exec(code, run_globals)
File “/usr/lib/rhasspy/rhasspy-wake-porcupine-hermes/rhasspywake_porcupine_hermes/main.py”, line 15, in
import pvporcupine
File “/usr/lib/rhasspy/usr/local/lib/python3.7/site-packages/pvporcupine/init.py”, line 13, in
from .util import *
File “/usr/lib/rhasspy/usr/local/lib/python3.7/site-packages/pvporcupine/util.py”, line 54, in
_PV_SYSTEM, _PV_MACHINE = _pv_platform()
File “/usr/lib/rhasspy/usr/local/lib/python3.7/site-packages/pvporcupine/util.py”, line 47, in _pv_platform
pv_machine = _pv_linux_machine(platform.machine())
File “/usr/lib/rhasspy/usr/local/lib/python3.7/site-packages/pvporcupine/util.py”, line 23, in _pv_linux_machine
hardware_info = [x for x in cpu_info.split(’\n’) if ‘Hardware’ in x][0]
IndexError: list index out of range
^C2021-04-01 19:13:18,275 WARN received SIGINT indicating exit request

I would bang an issue on https://github.com/Picovoice/porcupine/issues as the error is with pvporcupine and not sure why they do what they do but when you do a lscpu it does not return a shape that they are expecting.

I recognise the error from a vanilla install of pvporcupine that didn’t include rhasspy so pretty sure there is nothing rhasspy can do apart from maybe state if the RockPiS is or is not supported.

Your alternative is to change KWS but the options are not that great as pvporcupine was prob the best and even then its really just a freebie carrot model to their commercial custom model offerings.

The Issue is resolved, for now.