Rhasspy-voltron startup fails - No such file or directory: 'profiles/defaults.json'

Greetings. After reading about rhasspy-voltron, I was very intrigued as it seems to include all the features I could hope for, especially the satellite/server capability.

I installed it using the instructions at https://github.com/rhasspy/rhasspy-voltron on my new Rpi4 with the Raspbian GNU/Linux 10 (buster) full image.

The installation went smoothly with only one error. Log output ended with:

Installing development requirements
ERROR: Double requirement given: coverage==5.0.4 (from -r requirements_dev.txt (line 4)) (already in coverage==5.0.2 (from -r requirements_dev.txt (line 3)), name=‘coverage’)
Failed to install development requirements
Using virtual environment at /home/pi/rhasspy-voltron/.venv
INFO - Cleaning site directory
INFO - Building documentation to directory: /home/pi/rhasspy-voltron/rhasspy-server-hermes/web/docs
INFO - Documentation built in 3.30 seconds

Not sure if this is related to my issue, but included it just in case.

My failure occurred when I entered the startup command:

./rhasspy-voltron --profile en

Unsure if this is the proper syntax. The run instructions said:

Run the bin/rhasspy-voltron script with a --profile <LANGUAGE> argument.

Output from the command was:

pi@rpi4:~/rhasspy-voltron/bin $ ./rhasspy-voltron --profile en
Starting up…
DEBUG:main:Namespace(debug=True, docker_compose=’’, local_mqtt_port=12183, profile=‘en’, supervisord_conf=‘supervisord.conf’, system_profiles=PosixPath(‘profiles’), user_profiles=PosixPath(’/home/pi/.config/rhasspy/profiles’))
DEBUG:main:Loading profile en
Traceback (most recent call last):
File “/usr/lib/python3.7/runpy.py”, line 193, in _run_module_as_main
main”, mod_spec)
File “/usr/lib/python3.7/runpy.py”, line 85, in _run_code
exec(code, run_globals)
File “/home/pi/rhasspy-voltron/rhasspy-supervisor/rhasspysupervisor/main.py”, line 91, in
File “/home/pi/rhasspy-voltron/rhasspy-supervisor/rhasspysupervisor/main.py”, line 69, in main
profile = Profile(args.profile, args.system_profiles, args.user_profiles)
File “/home/pi/rhasspy-voltron/rhasspy-profile/rhasspyprofile/init.py”, line 46, in init
File “/home/pi/rhasspy-voltron/rhasspy-profile/rhasspyprofile/init.py”, line 82, in load_profile
with open(defaults_path, “r”) as defaults_file:
FileNotFoundError: [Errno 2] No such file or directory: ‘profiles/defaults.json’

Any suggestions to resolve this would be greatly appreciated.

dont know if it will help but here’s the command i used to install rhasspy on both my server and satelites

docker run -d -p 12101:12101     --restart unless-stopped     -v "$HOME/.config/rhasspy/profiles:/profiles"     --device /dev/snd:/dev/snd     rhasspy/rhasspy:2.5.0-pre     --user-profiles /profiles     --profile fr

you should stop and remove the docker containers first ( that s what i did )

docker stop $(docker ps -a -q)
docker rm $(docker ps -a -q)

carefull those 2 last commands will stop and delete ALL your containers

Thanks for the reply lilbuh.

I tried to get started by installing rhasspy-voltron from the git hub site. Bad idea.

I found good instructions at https://rhasspy.github.io/rhasspy-voltron/tutorials.html#server-with-satellites.

Installed server image successfully with docker. Now working on a satellite image on my rpi2 (may be too slow, but will try it).

Thanks again.

well since most of the work is done by the server it should work ok i will test soon on a raspberry pi zero W as a satelite wich is the equivalant of a raspberry pi 1

I encountered the same problem while testing a venv install, and after opening an issue on GitHub someone pointed me in the right direction to solve it. Have a look there for the solution.

Thanks, koan for the response. Although I had good success with the docker install (got satellite/server working to at lease recognize a wake word and interpret a vocal command), I wanted to try out the .venv setup.

I restarted with a fresh Buster-lite install. Followed the suggestions in the git issue you mentioned. The two ‘git submodule …’ commands appeared to run ok.

Not sure if I executed the last two commands correctly. I did this:

From within dir /home/pi/rhasspy-voltron:
source .venv/bin/activate
pip install supervisor (seemed to install ok)
sudo apt install mosquito (says it’s already installed)

Now rhasspy starts and stays up, but produced an error about:
No module named ‘num2words’
I’ll research this and do some testing.

Thanks again for the helpful response.

Oh right, don’t forget to make again after all this :slight_smile:

I also prefer the Docker install, but I couldn’t get the Precise wakeword working there, so I tried it in a venv (no success either).

The ‘make’ did the tirick.

My satellite is still using docker and snowboy, but I’ll try Precise on it before and after I convert to .venv and let you know how it works for me. I’m using respeaker 2-mic Pi hat.