Rhasspy falls back to english profile after reload

Dear all,

I installed Rhasspy via Docker with german profile. German files were downloaded at first start - until then everything worked fine. But when I edit the settings and reload Rhasspy suddenly Rhasspy shows an english profile.

I even deleted the english profile folder.

What did I do wrong?

  • Rhasspy version: 2.4.18
  • hardware: Raspberry Pi 4
  • OS: Raspbian Buster

I’ve encountered this issue as well. Doing a hard restart of the container is doing the trick. Sometimes annoying but effective. Maybe it’s better working with 2.5

1 Like

Thank you for the quick reply.

2.5 isn’t there yet, is it? I used the :latest version.

No not yet. Soon hopefully :slight_smile:

Killing the Rhasspy-Docker-Container helped for a while.

But after editing the Words tab killing the container does not help anymore.

Now only the english profile loads and I get an “Error: Network Error”

I broke Rhasspy :frowning:

In noticed the same issue and have been restarting it several times and switching between browsers. One of these methods resolved it :blush:

It seems like something in my profile folder is corrupt: I deleted the docker container, reinstalled it, deleted it again - and now I even downloaded the pre-version of Rhasspy 2.5.

BUT: Under my IP:12101 I only get an error.

I deleted my profile and rebuild the Rhasspy Container. Now it works again. So the profile was indeed corrupt. But I do not know why.