Rhasspy don't understand any voice input from microphone

I installed Rhasspy on Docker of Raspbian. But it seem Rhasspy didn’t detect what I speak and transfer speech to text. It just display “Listening for command” when I hit wake up button on web interface, then nothing occur until Timeout Error.

Even I test microphone on Raspbian independently by command on console to record and play recorded audio .wav file. Microphone record wells, I can play record file and hear my voice.

But when using with Rhasspy, Rhasspy seems didn’t receive any input signal from microphone, even it’s displayed “working” when I click test in the settings of Audio Input.

Picture is Rhasspy log after Timeout.

Please help me.


try to test arecord and aplay from Rhasspy docker container
like this

Thank you for your support. But it still failed. Picture below is log of console.

You are passing wrong parameters to the command:

arecord -D plughw:2,0 -d 5 test.wav
and then
aplay -D plughw:1,0 test.wav

I change the other microphone. It works well to record with arecord and play with aplay to the my speaker.

But I have still encountered to the error with train. I edit the sentences, then click train. But error show in the bottom as picture.

For English profile. It works very well. But for Vietnamese profile, the system encountered that problem after downloading missing file and train.

Figured out how to fix mine. I’m using a Pi 4b, Rhasbian 11, Rhasspy 2.5.11, Cheap USB mic

I had to use arecord and device plughw:CARD=Device,DEV=0

I have a separate Intel NUC that is running the HASS with Rhasspy installed on it and it worked fine with the default settings with Pyaudio. Must be a Rhasbian thing.