Rhasspy Docker + ReSpeaker 2-Mics Hat

Hi there,

So I’m a total noob with Rassphy. I’m using this in a thesis project and I also bought the ReSpeaker 2-Mics HAT to use as a microphone and output device. The problem is I can use it to record, but the sound only outputs from the Pi itself, I tried a bunch of different things and I just can´t get it to work. Can you guys help me, please?

I’m using a docker image of Rhasspy,
porcupine wake word and the rest is just default. Except for the sound part, that I tried every possible device it showed up, and it showed up the seeed2micsvoicec, as expected.

I set up rhasspy 18 with a lot of trouble.(no trouble with 16)
It crashes regulary after a few outputs. (Respeaker 2 Mic)
I changed the output device in the gui to:
This solved the crash. It was an error in pulse, which is well known. Check the syslog
Tail /var/log/syslog -f
Ig rhasspy restarts, try my option

I managed to get it, had to write directly in profile.json

I have the ReSpeaker 2-Mics Hat and I also have a cheap speaker plugged into it. I think you need a separate speaker and the ReSpeaker 2-Mics Hat is just the 2 microphones (plus other stuff that isn’t a speaker).

“JST 2.0 SPEAKER OUT: for connecting speaker with JST 2.0 connector
3.5mm AUDIO JACK: for connecting headphone or speaker with 3.5mm Audio Plug”