Rhasspy Android, Wall Panel or HA Companion App?

Hi Folks, looking for a little advice/direction. Been very happy with my Rhasspy running on a dedicated RPi4 and my HA running in a docker on a separate box. I was able to pick up an android tablet, with the goal of putting this in a different area of the house. But, having some issues; first, I want my existing Rhasspy to continue to work, and I’m having difficulty setting up the Rhasspy Android app (specifically, I want to continue to use “Hey Mycroft” as my wake word, and I’ve had no luck trying various configurations while leaving the main Rhasspy “active”). So, I tried WallPanel, and it has a lot of features (ability to push to the android app to change configurations) but no voice component. I then tried the HA companion app, but even though I’ve read the threads, I’m running into the same issue on the wake word. Finally, I did see “OpenWakeWord” and have thought about setting it up in a docker, and then pointing both my main Rhasspy and the Android to it for the wake word, but I’m a little confused about Wyoming and the direction Rhasspy and HA are taking.
Any advice or direction appreciated.

Which Android App did you try?


with the second one i can maybe help you out to get wake word to work.

Hi Nailik,
Thank you so much for responding to me. I’m using your app. I think I’ve found my issue, but maybe you can confirm. I’m now thinking that the “main” Rhasspy can not be set up to work with wakeword, microphone etc. (e.g. a fully functional Rhasspy) if you’re going to connect the android app to it. Am I correct?

No you should be able to use your that’s spy server as is.

Okay, I’m really stumped then. I’ve tried multiple configurations, I’ve even added an “OpenWakeWord” server into the equation, and I’m unable to get the android side going. I’ve tried Hermes MQTT & the remote HTTP configurations, both with the OpenWakeWord server, and without, and I’ve got MQTT.fx running, and I’m unable to have both the WakeWord functionality work with the Intent Recognition.
I’ve looked through your thread, and reviewed the Rhasspy docs, and I’m really at a loss as to how to proceed. I’d really, really like to stay with my Rhasspy → HA setup, rather than switching to the HA Voice (my hardware is old, and I don’t think I’d get very good performance from Pipe/Whisper) but also really want to add the android satellite into the mix. I know, cake & eat it too. :slight_smile: Any direction would be very much appreciated!!

First are you using Rhasspy3 is Rhasspy2.5?
Could you share the server configuration as well as the app configuration (settings → export). This would help to find out the problems.

Hey Nailik,
Just saw that I was on an old version of app (via FDroid). Pulled directly from github, and now having an issue with mqtt. When I enter my moquitto broker I’m getting this error message:
client initialization error
no NetowrkModule installed for scheme “http” of URI “
I’ve tried mqtt:// and not entering the port (which, in the version I was previously using, was entered on a separate line.
This is version 0.5.6-147.
I’m sorry to bother you with this, really don’t want to cause you an extra work by having to look at logs when I wasn’t doing something as simple as not updating the app.
Thank you again,

You need to write tcp://

Thank you again Nailik, both for creating the application, and your help. The change to tcp resolved the mqtt broker issue, but I’m not sure if I’m making a similar mistake on the Home Assistant Server. I’ve tried http://serveripaddress:8123, and just serveripaddress:8123 and I don’t get anything beyond “pending”. I’ve also tried disabling the ssl certificate validation. Also, on the Rhasspy2/Hermes Server, should I be putting in the “full” version of the Rhasspy ip address (if this is the case, not sure about the access token). Last couple of things, I’ve found if I force stop the app (which I’ve tried to see if it make a difference in connection to the HA server) a lot of the configuration information seems to be lost and I need to reenter it. (Speech to Text, Intent Recognition, Text to Speech) Is this because I haven’t successfully configured the app completely and the setting aren’t be written out? Finally, it would be nice if there was a way to delete the log, it would make troubleshooting a little easier.

Thank you!!

There should be nothing lost when force closing the app. I need to look into the issue.
I’ll add the delete log feature to my backlog, thanks for the idea.