Rhasspy Add-on for HA not listing my mic and speakers

Hello everyone!
I have Home Assistant OS installed on a Pi4, Rhasspy 2.5.11 was installed from the Add-on store.
For mic and speakers I plan to use a cheap USB speakerphone. I connected it to the Pi and rebooted the host. After this mic and speakers appeared in the Add-on configuration tab as BY Y02 Analog Stereo both for mic and speakers.
2023-01-28 01_07_22-Home Assistant

After starting Rhasspy I dont see such a device in the device list for recording and playback.
The devices listed in the recording section are:

The “test” button does not show any of them as “working” rather than “discard all samples”

Same with the playback device list

I tried to configure and test the wakeword, but had no reaction with all options from the record device list (most hopes were with the default device).

Same with the playback device. I test it with TTS and did not manage to get any sound.

The speakerphone is definitely not faulty. On a Windows computer is gets recognized and works fine.

I can post any logs, profiles if this helps
Thanks in advance!

have you read the other threads here about the same issue ?

You have Home Assistant OS, which means Docker is installed. Have you followed the suggestions for giving Docker containers access to the audio devices ?

Thank you so much for the response!
I am a complete noob in linux and docker stuff (that’s why I chose Home Assistant OS install).
I tried searching the forum for similar issues, but did not realize this is related to container access. I will try to look at these topics more deeply now.

Ok, this is complete gibberish to me, but I’ve found that you have to replace “- /dev/snd” with "–device /dev/snd " in the docker-compose.yml of Rhasspy
Is this the way to go? I am just afraid to completely mess up something )

Setting "–device /dev/snd " in the docker-compose.yml did not help…

I supposed the Add-on for HA should work “out of the box” with recommended settings, and it turns out you have to mess with docker configuration to get it working (((

I’ve found some other recommendations on the web, like changing device in the docker-compose to /dev/snd:/dev/snd, sometimes in quotes, but that did not help either

Also, examples of docker-compose, like this one

look quite different from what I observe in the share\rhasspy\profiles\en\docker-compose.yml

Just for clarification, is the container built every time I restart Rhasspy? I mean, is restarting Rhasspy enough for changes in docker-compose.yml to be implemented?

Which shell commands do I use to check if sound devices are visible inside the container?

Nope you have to delete that container and do the changed docker run again.

At least with the rhasspy docker image, the image is still there but the container runs detached -d

docker container ls -a
docker stop <container-id>
docker container rm <container-id>
“From my bad memory”

docker run -d -p 12101:12101
–name rhasspy
–restart unless-stopped
-v “$HOME/.config/rhasspy/profiles:/profiles”
-v “/etc/localtime:/etc/localtime:ro”
–device /dev/snd:/dev/snd
–user-profiles /profiles
–profile en


Thanks for the hint!
But it gets trickier than this )) Eventually, docker command is blocked in the Terminal and SSH add-on. You have to turn off “Protection mode” in the addon settings to access this command. For this switch to appear you need to have “advanced mode” for the user enabled in HA. I do have it enables, but I don’t see the Proteciton Mode swithc in the Terminal add-on…
Anyways, there is this “ha docker” command for managing docker there, but it does not give much info. Even with the Rhasspy running it shows nothing
2023-01-29 15_54_19-Terminal – Home Assistant

Yeah sorry Yari I have rudimentary docker knowledge but nothing of HA.