Rhasspy 2.5 intent handling using mqtt topics


I guess I’m just to silly today to get my intent handling working again…

Anyway. I have configured rhasspy to use an external mqtt broker. Using the speak feature is working and the bytes are published to the right topic. But triggering intents is just not working.

Seems for me like rhasspy isn’t publishing anything to hermes/intents/#

thats my log for one intent:

[DEBUG:2020-04-24 18:57:18,019] rhasspyserver_hermes: Publishing 21 bytes(s) to rhasspy/handle/toggleOn
[DEBUG:2020-04-24 18:57:18,019] rhasspyserver_hermes: -> HandleToggleOn(site_id='default')
[DEBUG:2020-04-24 18:57:18,017] rhasspyserver_hermes: Sent 262 char(s) to websocket
[DEBUG:2020-04-24 18:57:18,015] rhasspyserver_hermes: Handling NluIntent (topic=hermes/intent/GetTime, id=b31415d0-9564-441c-a96e-f652e56b0ff2)
[DEBUG:2020-04-24 18:57:18,014] rhasspyserver_hermes: <- NluIntent(input='wie spät ist es', intent=Intent(intent_name='GetTime', confidence_score=1.0), site_id='default', id='2a01f0ee-efa6-4cc9-b1ad-892c0b51d08e', slots=[], session_id='2a01f0ee-efa6-4cc9-b1ad-892c0b51d08e', custom_data=None, asr_tokens=[[AsrToken(value='wie', confidence=1.0, range_start=0, range_end=3, time=None), AsrToken(value='spät', confidence=1.0, range_start=4, range_end=8, time=None), AsrToken(value='ist', confidence=1.0, range_start=9, range_end=12, time=None), AsrToken(value='es', confidence=1.0, range_start=13, range_end=15, time=None)]], asr_confidence=None, raw_input='wie spät ist es', wakeword_id=None)
[DEBUG:2020-04-24 18:57:17,995] rhasspyserver_hermes: Publishing 195 bytes(s) to hermes/nlu/query
[DEBUG:2020-04-24 18:57:17,994] rhasspyserver_hermes: -> NluQuery(input='wie spät ist es', site_id='default', id='2a01f0ee-efa6-4cc9-b1ad-892c0b51d08e', intent_filter=None, session_id='2a01f0ee-efa6-4cc9-b1ad-892c0b51d08e', wakeword_id=None)
[DEBUG:2020-04-24 18:57:17,993] rhasspyserver_hermes: Publishing 21 bytes(s) to rhasspy/handle/toggleOff
[DEBUG:2020-04-24 18:57:17,992] rhasspyserver_hermes: -> HandleToggleOff(site_id='default') 

I’ve subscribed just for testing to hermes/nlu/query as well. And there I’m getting everything.

What haven’t I configured right? As I’ve understood the docs rhasspy publishes all intents on ws and mqtt doesn’t matter whether HA is configured for intent handling.

My settings:

Home Assistant receives my intents correctly. They are just not published inside rhasspy my guess.

It’s hermes/intent/<INTENT_NAME> you have to listen to.

See the MQTT API reference documentation.

Check this with:

mosquitto_sub -h -t 'hermes/intent/#' -v

I’m too dumb to read right. Thanks for your super fast answer.