ReSpeaker 2 Mic hat on Buster

I has the wrong idea to update/upgrade my buster install on both Pi before getting rhasspy latest.

All went fine and worked, until I reboot.

No more sound card recognized. Same with aplay / arecord -l

Did the standard install:

sudo apt-get install git
git clone https://github.com/respeaker/seeed-voicecard
cd seeed-voicecard
sudo ./install.sh

Got error, never had this problem before

Building module:
cleaning build area....
make -j4 KERNELRELEASE=5.10.11-v7l+ -C /lib/modules/5.10.11-v7l+/build M=/var/lib/dkms/seeed-voicecard/0.3/build....(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.10.11-v7l+ (armv7l)
Consult /var/lib/dkms/seeed-voicecard/0.3/build/make.log for more information.
Can't compile with this kernel, aborting
Please try to compile with the option --compat-kernel

Also tried sudo ./install.sh –compat-kernel with same result

Any idea how to install Respeaker 2mic on lastest Buster ?

Strange, after some times, retried sudo ./install.sh –compat-kernel and it finnally installed after a lot of stuff …

This downgrades your kernel.

Better use HinTak’s fork:

1 Like

Yes reading all le log it indeed downgraded my kernel.

Anyway on your link, installation is exactly the same, how does you get it from hintak ?

git clone https://github.com/HinTak/seeed-voicecard

The rest of the installation is indeed the same.

2 Likes

I don’t have any issues using the official Seeed files anymore. They updated their repo on GitHub some time ago with the changes from HinTak.

Cool, even without downgrading the kernel? I’ll try this next time I reinstall a Rhasspy satellite on Raspberry Pi OS Buster.

They integrated the fixes from the HinTak branch but they haven’t done much since then. HinTak still works on fixing more of the drivers, mainly crashes with 64bit systems and ubuntu but HinTak is still the more current fork.