Raspberry pi zero satellite delay

Hi i’m trying to use rhasspy (2.5.11) on a pi zero as a satellite. There is also an instance of raspotify running. It’s using a seeed mic2 hat and processing only recording, wakeword and output. It’s a docker installation. Everything works, with some little bugs, but there is a huge delay in getting the anwser, it stops recording very late. Does someone experience the behaviour? Is it the bad wlan module?

I solved it by my own. It turned out that there was a kind of “plopping” in the microphone recordings, so i had to listen to the mic while i was playing with the alsa settings. The plopping had a huge effect to the recognition.

 'arecord -f cd -t wav' | aplay -