Range number not working properly

I’m experiencing a very weird issue.
White getting familiar with template syntaxes, I just tried the following in my sentences.ini:

[SetBrightness]
set brightness to (low:0 | medium:0.5 | high:1){brightness!float}

But it didn’t work. Using rhasspy-nlu package, If i enter the string “set brightness to low”, it returns an empty result.

If I try the followng:

[SetBrightness]
set brightness to (0…100){brightness!int}

It doesn’t work either.
Is there something wrong in my syntax ? Or something is missing in my config. Knowing that I’m using rhasspy-nlu independently from the whole base system.

I’m desperatly trying to get things working but it failed.
I firstly thought that my syntax was bad, but I tried some examples of the tutorials and it didn’t work much better.

Ex.

[ChangeTemperature]
set temperature to (4…61){degrees!float}

If I try to recognize:

set temperature to ten

It does not work.

Any idea ?

Try two dots, 3 is typically used as a spread operator.

[ChangeTemperature]
set temperature to (4..61){degrees!int}
1 Like

It was copy/paste issue. I tried with “…” with no success :frowning: