Python slot_program

Hey everyone, i tried writing a python slot programm that simply copies the example (printing red, green and blue). However when i try refering to in in the sentences.ini file like this
color = ($ {color}
when I save for the first time I get an
"AssertionError: Failed to find ending '>' " error
Any subsequent saves will result in an
"AssertionError: No group preceeding literal"
I tried finding out the problem by checking out how the input is parsed but without actually knowing what the input is its quiete hard to figure out what is wrong and i dont know how i could display the input. When i try the bash example everything works fine. A hint for why im facing these problems would be very much appreciated

So I investigated a bit further. my progress so far is:
i have tried to use the get_replacements() method in the rhasspy-nlu module in isolation because thats where my error originates from. the get_replacements() method returns the values from the slot programm perfectly fineā€¦ is it maybe a outdated module problem in the docker image? i use the rhasspy/rhasspy image. is there a way to update the rhasspy-nlu module in that container somehow? using pip freeze shows me no rhasspy-nlu module at all. So im left wondering how the parsing is actually handled. Any pointers are still very welcome :smiley:

Update: rhasspy uses virtual envs for the submodules apparently thats why pip freeze didnt show anything. I tried using the version of rhasspy-nlu for the isolated get_replacements() test that is in the requirements.txt which is 0.3.0. Works fine so no idea still whats going wrong

Update: I have given up using slot programs as the far better approach seem to be to use the rest api to set slots. In my opinion that should also be the recommended way in the documentation. Anyway for anyone having similar issues, save yourself the hassle and use the api.

Have you tried it without the .py file extension? This may be causing the issue.

Is this in rhasspy 2.5 or 3.0?