Problems with microphone when setting mqtt

So as i write in my thread before, i have this problem:

when enebaling mqtt, i dont see my microphone selectet in the settings anymore… why? also i cant refresh, that gives me a TimeoutError… :thinking: do you maybe know what that problem is?

The question was, how i did set up The Pi:

Install Raspberry pi os lite 32 with update and upgrade
then installed docker with the script:

curl -fsSL -o
$ sudo sh

and also :

sudo usermod -aG docker $USER

then installed portainer:

docker volume create portainer_data


docker run -d -p 8000:8000 -p 9443:9443 --name portainer --restart=always -v /var/run/docker.sock:/var/run/docker.sock -v portainer_data:/data portainer/portainer-ce:2.11.1

and then rhasspy:

docker run -d -p 12101:12101 \
      --name rhasspy \
      --restart unless-stopped \
      -v "$HOME/.config/rhasspy/profiles:/profiles" \
      -v "/etc/localtime:/etc/localtime:ro" \
      --device /dev/snd:/dev/snd \
      rhasspy/rhasspy \
      --user-profiles /profiles \
      --profile de


Ok, so I see a few things, I’d do different. :wink:

First and foremost, if you don’t use portainer, uninstall it. :slight_smile: I’d only use portainer, if I had a lot of different docker containers/images to manage. I assume this is not the case here. For one container (Rhasspy) it is simply not necessary.

Second, I’d use docker-compose to setup your different or just the one container. It makes restarting and changing things a lot easier. In short, docker-compose does the same as you’d do yourself with your docker command from above. But as it is written in a file, you always have your settings and everything else at hand. Makes life easier. Imho docker-compose is, what most people expect from portainer.

This isn’t a solution to your problem, but will make it easier for you, especially in the long run. :slight_smile:

Regarding your problem. What Pi are you using? Can it be, that the system use is too high? Just for a short check, open SSH and logon to your Rhasspy-Pi and call “htop”. It should show you the actual running threads, cpu and ram use and such things. Then open your config page in the browser and do some things. If htop reports a lot of cpu use, that could be the problem. :slight_smile:

The docker run shares the hardware --device /dev/snd:/dev/snd but not any asound.conf as what is on the host is not in the container.
Often that is a cause of problems.
-v "/etc/asound.conf:/etc/asound.conf" is sometimes needed if a asound.conf is used

Its prob best to ssh into the container and actually test the device in the container but prob need to stop services accessing that source.
docker exec -it <container name> /bin/bash

Inside the container arecord -D plughw:1 -V mono -r 16000 -f S16_LE -c 1 /dev/null changing plughw:x to the index of your device arecord -l to list.
That will show a cli VU meter whilst you test your mic.

just to be sure, i need to do this also when i can use the mic. Without the mqtt set to “external” ?
I mean, the Mic works, it does record what i talk.
Just when i change to mqqt “external” stuff dont going anmore.

I have also Node red runing on it. and i am not that fimilar with coding and so on, so i like to have a dashboard :sweat_smile: but yeah i will check out docker compose, i also heard a lot of it, but never checked out :wink: could i also use it with portainer? :laughing:

i also have it on b.c. i don`t know if i would add more to the pi (pi hole or so) also the official instal was like this, so thats why i did it.

So you didnt read my other thread post completly or just forgot it :stuck_out_tongue_winking_eye:
i use a Raspberry pi 3b. And the usage of the pi is realy low. that should not be the problem. It`s mostly under 10% , when i change a setting then it goes up for a short time (reboot) but it cools down fast.