Probleme with tag


I am French, so indulgence!
First congratulations on your job.
I use rhasspy, (docker, marytts, snowboy, no HA).
It worked well.
Today, if I write: (open) {action: ON}
my json returns action: open
I reinstalled, without success
You have an idea?

Bonjour (bon soir!) @kookic My French is horrible, but bienvenue!

Here is a segment of my Rhasspy sentences:

lamp =  (rabbit | brass | dog | bedroom | outdoor) {lamp}
status = ( on | off | toggle ) {status}
( turn | switch ) <status> [the] <lamp> [lamp] [lights]
( turn | switch ) [the] <lamp> [lamp] [lights] <status>

and this is returned in Home Assistant as the intent:

    "event_type": "rhasspy_ChangeLampState",
    "data": {
        "status": "off",
        "lamp": "dog",
        "_text": "turn off the dog lamp",
        "_raw_text": "turn off the dog lamp"
    "origin": "REMOTE",
    "time_fired": "2019-12-29T17:57:31.138425+00:00",
    "context": {
        "id": "8d570b41039d42ed94bee23b348a3488",
        "parent_id": null,
        "user_id": "26ec3060f78f4880a6a70e903924eb1f"

when I speak “turn off the dog lamp” which matches the first sentence syntax

Hope this helps!

Yes thank,
no problem, for:
status = ( on | off | toggle ) {status}
but y want:
status = ( on | up ) {status:ON}
for a return in json… “status” : ON,

You see?
my english is worse!

Alternatively, you can put this in a state slot:
( on | up ):ON

And use it like this:
turn the light ($state){status}

It works for me.

Also, have you tried using only lowercase?

Hope this helps.

Thank fastjack bur idem
In the doc the example =

Tag Synonyms

Tag/named entity values can be (substituted](#substitutions) using the colon ( : ) inside the {curly:braces} like:
turn on the (living room lamp){name:light_1}
Now the name property of the intent JSON event will contain “light_1” instead of “living room lamp”.

Why not work? before it worked

Have you tried using only lowercase?
I had strange issues with mixed uppercase/lowercase. Using only lowercase solved them.

yes y using only lowercase

Something must be broken regarding substitutions then.

It works perfectly using slots though.

Let’s see if @synesthesiam has an idea of what might be going on.

I just reinstalled the dock, erased the volume, with a single sentence … same problem
for example
il est quelle (heure){mot:horloge}
“mot”: “heure”

Y confirm, have installed 2.4.15 on other (Orangepi/armbian ), alternatives not work

well, if i use fuzzywuzzy not work
But with OpenFST, no problems