Problem with Gstream + Rhasspy (audio source from odas)

Hello,

I am having trouble with using Gstream with Rhasspy. I am using Raspberrypi with Matrix creator board. My plan is to use ODAS to get direction of the voice and forward the audio from odas to Rhasspy via Gstream, since apparently it is not possible for two applications to use the Matrix board simultaneously.

First, the successful try: Streaming my microphone from my laptop to Rhasspy on Raspberrypi

gst-launch-1.0     autoaudiosrc !     audio/x-raw, rate=16000, channels=1, format=S16LE !     udpsink host=192.168.0.3 port=12333

Rhasspy settings pipeline:

udpsrc port=12333 ! rawaudioparse sample_rate=16000

This worked for me with the older Rhasspy version (2.4.20) but was not able to get it work on the latest (2.5.7).

So I continued with the older version forward. I opened port in ODAS to get the audio. (In the sss part of config, in the ‘matrix_creator.cfg’)

separated: {

    fS = 16000;
    hopSize = 128;
    nBits = 16;

    interface: {
        type = "socket";
        ip = "127.0.0.1";
        port = 10000;
    }
};

Then I tried to get the audio to my laptop so I could hear it. (Since my “just wing it” try with Rhasspy did not work).
So I ran command below on raspberry.

gst-launch-1.0 tcpserversrc host="127.0.0.1" port=10000 ! rawaudioparse sample-rate=32000 !  udpsink host=192.168.0.2 port=12332

And this one on my laptop

gst-launch-1.0     udpsrc port=12332 !     rawaudioparse sample-rate=32000 !     pulsesink

And I was able to hear audio loud and clear. Changing the sample-rate to 16 000 made the audio really bad (Could have been alien voices from movies…). As I was able to hear it working I advanced to try to feed it to Rhasspy. Using the same Rhasspy pipeline as above I tried the following command on Raspberry.

gst-launch-1.0 tcpserversrc host="127.0.0.1" port=10000 ! rawaudioparse sample-rate=32000 !  udpsink host=127.0.0.1 port=12333

Aaand nothing. Rhasspy did not react to the voice. I tried changing the sample-rate to 16 000, I tried giving the format information pcm and pcm-format=s16le, I think, in all possible combinations but Rhasspy did not recognise it.

Is there something that I am doing wrong? Any tips would be appreciated

Thanks for your time!
-Joni