Problem mic occuped

Still need you!
i use alsa
The microphone is occupied by rhasspy (docker), cannot use another application to record. However, I snooped the device in “asound.conf”. No problem if I don’t use rhasspy, I can launch arecord and audacity for example.
You see?

Odroid xu4 / docker / No HA

Hmmm… As iknow snooping should work, but haven’t tried it.
Btw, did you change mic in rhasspy settings?
Is it using dsnoop?

This sounds like the problem I had when trying to make an intercom. Rhasspy in Docker is using the mic (I had a lot of problems changing the default mic in Rhasspy and just quit because I couldn’t get it to work with any alsa, even though it worked fine if Rhasspy wasn’t running) and nothing else can access the mic. I didn’t solve the problem.

it’s not good news!
I need to register words in my python program to add them to a list. I did it with Snips
Do you have an idea?
yes for ‘dsnoop’

I tried my ideas and they all failed :rofl: and I have very little experience with Docker or Pis. But maybe someone else can tell us how to get around this :crossed_fingers:

Could you try it when you get a chance? I had a similar issue and don’t know how to get around it. Thanks!

With docker impossible. I installed rhasspy .env
and there it works.
Michael warned us in his doc!

A little advice to manage docker install portainer
it will make your life easier!
I also use webmin to manage Linux commands.

1 Like